New answers tagged

0

i encountered your post after i run in the same issue with Apple Mail I could solve why this problem occurs. I also setting up a Rule in Apple Mail with multiple actions who moved the mail to another folder/mailbox and then executing a Applescript - (i was archiving attachments with the script - nothing fancy) It now happens in Catalina that Apple Mail ...


1

Have you tried removing/deleting those files and folders through command line using terminal ? Open Terminal type rm -r followed by Space Drop&Drag the files/folders to be deleted into the Terminal window (so the file path gets inserted) Press Return


0

Response from FTDI regarding signed drivers Apple are moving from what are called Kernel Extentions (.kexts) to what are called Driver Extensions (.dexts) for the implementation of drivers starting in macOS Catalina (10.15). Currently .kexts are still supported in macOS Catalina, however after the beta release they issued an update which stopped our driver ...


1

You need to give Terminal Full Disk Access in System Preferences > Security.


1

If Terminal isn't showing up in the System Preferences list for microphone permissions, open it by: open /System/Applications/Utilities/Terminal.app/Contents/MacOS/Terminal Then run a program that uses the mic e.g. sox -d -d (Not a pre-installed program. This will let you hear your mic input) That should trigger it to request. If that didn't work try ...


1

You'll be able to read the directory if you grant Full Disk Access to your terminal program. Apple Menu › System Preferences › Security & Privacy › Privacy › Full Disk Access.


1

I solved the probelm by setting the permissions in the following way: sudo chmod -R +a "user:USER_NAME allow list,search,readattr,readextattr,readsecurity,file_inherit,directory_inherit" PATH_TO_DIRECTORY/ This does the trick of changing the folder permissions so it propagates the users permissions automatically when new files are added. In this example ...


1

Even if an application can run as root, in macOS Catalina and some previous versions, SIP prevents root from making changes to certain protected files. As of macOS Catalina, system files are stored in a separate volume that is mounted read-only. As for the privacy settings, applications even if they run as root must ask and get permission from the user in ...


1

If you need to create directories off the root, the best option is to use firmlinks, which can be configured using /etc/synthetic.conf. From the manual page: ... synthetic.conf is intended to be used for creating mount points at / (e.g. for use as NFS mount points in enterprise deployments) and symbolic links (e.g. for creating a package manager root ...


1

I downloaded the install package from the site https://www.anaconda.com/products/individual and ran through a default install. It looks like the application is installed in /opt. You will need to use sudo rm -rf /opt/anaconda3 to delete. Please review terminal session below: (base) users-MacBook-Pro:~ user$ cd /opt (base) users-MacBook-Pro:opt user$ ls -...


0

Based on I manually set the owner from root to myself. It seems that you are downloading/installing software as root user, did you enabled root access four your own user? If yes you must disable it.


4

You have run into System Integrity Protection ( SIP ) which protects certain system folders from being changed. https://support.apple.com/en-us/HT204899 To make the copy anyway, you turn off SIP. Be sure to turn SIP back on when done. It's a hassle. https://www.macworld.co.uk/how-to/mac/how-turn-off-mac-os-x-system-integrity-protection-rootless-3638975/ ...


1

Catalina mounts system directory's in apfs containers (think linux lvm volume) explicitly as read-only, yet another security feature. To access raw block devices you need to remount with explicitly adding rw options: bsd mount: mount -uw / or mount -X /, try to add -o remount I think, look at man mount and diskutil help I don't recall bsd mount opts now ...


1

I am working in a MacOS 10.15.4 environment with a /Sites folder migrated from a much older Mac. I used the instructions from etresoft to set up my server. Everything followed well until I reached the point "It Works!" In the following step I received the same HTTP Error Code that you do -- namely, 403. This problems was fixed by changing the values of ...


1

OK, it looks like I have found the answer. It's a problem in Finder. Finder apparently doesn't understand that 192.168.1.1/Data and 192.168.1.1/TimeMachine, despite they are advertised separately under AFP that require different credentials, are two different shares. If I connect to 192.168.1.1/Data, provide correct username and password, and browse that ...


0

On Catalina, you can't use the above solutions. What you can do is select the folder in which all images are located, go to the usual get info and change permissions for the folder. Once you are done with that, click on the lock icon and get administrator access to change permissions. Once you enter your password, click on the small gear icon at the bottom ...


Top 50 recent answers are included