New answers tagged

1

This is part of the handoff functionality. Which is indeed linked to an AppleID. You can easily disable handoff in System Preferences. System Preferences --> General And then uncheck “Allow Handoff Between This Mac and Your iCloud Devices”. More info on handoff at the Apple's website Pick up where you left off with Handoff on Mac.


Top 50 recent answers are included