27

You can try arp on the command-line: NAME arp -- address resolution display and control DESCRIPTION The arp utility displays and modifies the Internet-to-Ethernet address translation tables used by the address resolution protocol (arp(4)). With no flags, the program displays the current ARP entry for hostname. The host may be specified by ...


14

You sure can! Open System Preferences, then go to Sharing and select Internet Sharing. Change "Share your connection from:" to Wi-Fi, and then in the box below it select Ethernet.


11

Source of the problem By studying the processes spawned by InternetSharing (with the help of opensnoop and debugging shell scripts) I finally build a way to circumvent this systematic and stupid overwriting of /etc/bootpd.plist. InternetSharing creates a minimal /etc/bootpd.plist and then spawns 2 processes: /usr/libexec/bootpd /usr/libexec/natpmpd ...


11

InternetSharing does log which address gets a DHCP lease within: /var/log/system.log Technically it is the bootpd daemon which does take care of this part of the network access. You can track who is getting access to your network now with this command: tail -f /var/log/system.log | grep 'bootpd.*\[en.\]' and for Mavericks, Yosemite & El Capitan: ...


9

You can't "share" a Wi-Fi connection via a Wi-Fi hotspot. What is misleading everybody is the inapropriate use of the technical term of sharing when the function we are talking of is a redistribution. When 2 PC are connected on the same Wi-Fi hotspot they are truly sharing the same connection: they are using the same Wi-Fi channel, they are sharing the ...


8

I have experimented with using ControlPlane to achieve what you want. My preliminary result is that it will do what you want. ControlPlane detects changes to your system called 'evidence sources'. Changes are evaluated with 'rules' which define a change in 'context'. Associated with each context are 'actions'. One of the 'evidence sources' is a sleep/...


7

I found a relatively simple solution not involving a system restart - just bring the WiFi interface down and then back up: $ sudo ifconfig en0 down $ sudo ifconfig en0 up In my case en0 is the AirPort interface of my MacBook Air. Note that turning the AirPort off and on again doesn't work, but bringing the interface down does the job.


7

Short answer Until now (iOS 9.1) there has been no way to configure port forwarding in Personal Hotspot Long Answer Activating Personal Hotspot on an iOS device enables it's built-in NAT router. Other devices that connect to this iPhone (using USB, WiFi or Bluetooth) get an IP in the 172.16.0.0/12 subdomain. There are no NAT settings in iOS, nor does it ...


7

Sharing your source Internet using WiFi to your Ethernet output.


6

arp -a gives a list of connected interfaces on the same network. en1 is Wi-Fi en0 is Ethernet (on the Macbook Air this is Wi-Fi) How to use Type this command in the Terminal located at /Applications/Utilities/Terminal.app. To learn more about this command, type man arp in the terminal.


6

I finally figured it out. You said your Firewall is off. You should double-check. This will definitely cause Internet Sharing to not work. System Preferences -> Security & Privacy -> Firewall. In the "Sharing" panel, change your Computer Name to something simple. Instead of "Elliot's MacBook Pro", use "MBP". Turn off Internet Sharing (if it's on). Make ...


6

This all happens inside the "Sharing" pane of "System Preferences": Select "Internet Sharing" from the list Select "Ethernet" from the popup menu Click the checkbox next to "Wi-Fi" If you wish to secure the wireless network a password, click the "Wi-Fi Options..." button When you've got it all set up how you like, click the checkbox next to "Internet ...


6

Try pinging the broadcast address. This should work as long as the Pi got an IP from DHCP and responds to ping. First, open up a terminal and run ifconfig en0. This should give you the info for your ethernet interface, if not, just use ifconfig and find it yourself. Make a note of the broadcast address. In my case, it's 192.168.2.255: inet 192.168.2.99 ...


6

You need to select which networking the connection is to e share on. This is selecting at least one from the list in the bottom right hand of the preference pane. e.g. to share your ethernet connection over wifi and firewore


6

I found the answer. I loaded my rules as part of the anchor com.apple/100.InternetSharing/natpmp which is the one used for Internet Sharing. The file mitm.pf.conf contains the rules: rdr on bridge0 proto tcp from any to any port 80 -> 127.0.0.1 port 8080 rdr on bridge0 proto tcp from any to any port 443 -> 127.0.0.1 port 8080` Load it using the ...


6

The option is not available because you have selected to share your connection from Wi-Fi. You can't share your connection from Wi-Fi to Wi-Fi. Use an alternative method of obtaining a connection to the internet (e.g. Ethernet) so that the internet connection can be shared over Wi-Fi.


6

Sorry: I'm a bit short of time and so this isn't a complete answer, but hopefully it gives you a starting point. From the answers to this question, it seems that /usr/libexec/InternetSharing creates /etc/bootpd.plist when Internet Sharing is turned on, and removes it again when it is turned off. I think this file is the cause for the ifconfig values you ...


6

I've seen this issue before. I'm not sure why this happens, but have found that totally removing your Wi-Fi service, restarting your Mac, and adding your Wi-Fi service back again will resolve the issue. While you don't specify your version of macOS, the steps below should work: Go to Apple > System Preferences > Network Select the Wi-Fi service on the left-...


5

Yes it can use iCloud back to my Mac to locate remote Macs behind a NAT router. Also, if your network allows inbound network connections then that also would work over the Internet. And no, ARD is not a service where a client runs on each Mac to tunnel out of more arbitrary network connections as Team Viewer, Citrix/GoToMeeting and other solutions that are ...


5

Your Macbook is bridging 2 different networks. The first, from your router, would presumably be 192.168.1.0 That would make the router itself 192.168.1.1 & it will then hand out DHCP addresses from 192.168.1.2 up to as high as .254 In order to prevent potential IP Address conflicts. Apple's Internet Sharing will use an address of one order higher for ...


5

This is how I got it to work. My example uses three hosts on my network (10.10.0.0/16): 10.10.10.10 = Linux client 10.10.6.237 = Mac "real server" providing a service on port 3000 10.10.1.200 = Mac "server" performing pf redirection, listening on port 2004, interface vlan0 natrdr.pf rdr on vlan0 inet proto tcp from 10.10.0.0/16 to 10.10.1.200 port 2004 -&...


4

This thread along with https://discussions.apple.com/thread/2108373 helped me. I turned off all internet connection sharing. I deleted the following files: /Library/Preferences/SystemConfiguration/com.apple.nat.plist /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist ...


4

Try networksetup -setairportpower en0 off


4

This is specifically for Ethernet > Ethernet Sharing connections, rather than WiFi (it might work for WiFi but I haven't tested) - I thought the answer would best belong here, for Google. Tested as working up to El Capitan 10.11.5 Apparently since Yosemite, adding just the SharingNetworkNumberStart key is no longer sufficient. Also, System Prefs caches the ...


4

This is indeed quite broken in Mountain Lion. Once you've fixed up the default route as you describe in the question, you're still left with the problem that Mountain Lion is giving its bridge interface address to clients as both the router address (which is correct) and as the DNS server address (which isn't). Verify that this is the problem by entering an ...


4

I found the answer to my particular issue. The reason that my iPhone could not subscribe to a published Outlook .ics calendar was because the MIME type of the .ics file was wrong. As recommended in this brilliant post by Joe Bradford, I went into IIS, changed the MIME type from application/octet-stream to text/calendar, and iPhone could connect and ...


4

I've used Idea Netsetter Dongle and shared my internet over the Wifi. First connect to the Internet with Idea Netsetter 3G Open System Preferences > Sharing Select the Network which you want to share ( In your case it's Ethernet Adaptor ) Select the network(s) which you want to share the internet to (In your case Wifi) Don't forget to switch you're ...


4

I'm on Debian Wheezy too and this worked for me: Install Mac drivers from http://beagleboard.org/Getting%20Started Connect BBB to Mac through USB On the Mac, go to System Preferences > Sharing > Internet Sharing > Beaglebone Black In System Preferences > Network, make sure BBB is in the left hand side and shows “Connected” After SSH’ing into the BBB, run “...


4

I ran into the same problem when reverse tethering my Samsung phone (Android 5.1.1) to access the Internet connection on my Macbook Air (El Capitan), and found a successful solution: Make sure your mobile device is paired via Bluetooth and follow Heiko Haller's steps for Internet Sharing settings. Under System Preferences > Network, select the active ...


4

In System Preferences, go to networking and connect your Mac to a wired network. Firewire or thunderbolt or ethernet (with or without an adapter) is needed to have a physical connection in the green or orange state. You need a link up and not necessarily a viable connection to any network. Then go into Sharing and enable Internet Sharing, there, share the ...


Only top voted, non community-wiki answers of a minimum length are eligible