New answers tagged

0

Wrapping in quotes also works youtube-dl "https://www.youtube.com/watch?v=mkd6JkfI4yk"


1

First, execute in a terminal with zsh (Z Shell): echo 'export ENV_VAR=12345' >> ~/.zshenv Then, reload changes: source ~/.zshenv Finally, test if your new variable is set: echo $ENV_VAR Note: By standard, the .zshenv file should only contain environment variables setting commands. .zshenv is sourced on all invocations of the shell, hence it will ...


2

The solution is to source the file dependencies you need inside the automator script. Example if you added all of your scripts to ~/.zshrc source ~/.zshrc deploy You can debug things easier by doing which deploy to check to see if that script is accessible.


0

I solved same issue with Turn on System Preferences -> Security & Privacy -> Automation -> Go2Shell.app with Finder, iTerm.app or Terminal


0

You can't fiddle with /usr/bin: it's (SIP) restricted. To validate this understanding, just execute ls -laO /usr/bin So "resetting" this path as you seek to do is a non-starter. /usr/bin is full of binaries compiled by Apple themselves. For instance, if you execute /usr/bin/git --version you'll see the git that lives here is an Apple thingy; nothing ...


0

You can view/update current key bindings if you open the Preference window from the menu bar iTerm2 > Preferences > Keys > Key Bindings For me, command+←/→ as well as command+shift+[/] (as mentioned by previous answer) work by default. I am using iTerm2 (3.3.7) on macOS Catalina (10.15.2)


1

Especially since you're already using zsh, I would recommend using the existing highlighter framework (and builtin highlighters) of zsh-syntax-highlighting or fast-syntax-highlighting Based on a preliminary review, both should have sufficient documentation to hopefully allow you to set up your preferred environment. Here's a screenshot of zsh-syntax-...


1

After some more digging, finally a working solution! $ sudo su - # vim /etc/centrifydc/passwd.ovr Added this line: +username:::::::/bin/zsh::::::: Saved, back to the shell... # chmod 644 /etc/centrifydc/passwd.ovr # adreload # adflush Logout from macOS and login again, and default shell is now zsh. 🎉


1

zsh uses different config files, see the 'STARTUP/SHUTDOWN FILES' section in man zsh. You can run one of mv ~/.bash_profile ~/.zprofile mv ~/.bash_profile ~/.zshrc to rename the file, see the man page or https://support.apple.com/en-us/HT208050 for the difference between these: If you're using a bash profile, such as to set environment variables, ...


Top 50 recent answers are included