3

I have migrated from an old iMac running Catalina to a new one running Big Sur.

I assume, deep in the annals of time, I must have changed my default font in Mail for the Message List to be slightly bigger. It is set to Lucida Grande 12.

On the new iMac, this choice seems jarring in Big Sur.

On another iMac, migrated from a laptop where I had not changed the default font size, Mail shows my Message List font as System Font Regular 11.

When I go to change the font back to default, the font picker does not show any font called System Font, and I do not know what the actual system font is in Big Sur - is it Helvetica Nueue, San Francisco, or something else?

Ideally, how do I get rid of my custom font choice and revert to the default?

I am aware there are two similar questions here

Neither of them answer my particular question.

1
  • I have exactly this same question.
    – jdmc
    Aug 18 at 13:00
1

It may seem odd, but you can't find the "System Font" in the Font Picker. However, you can restore the default "System Font" setting for the message list (and then, if you like, use the Font Picker to adjust only its font size). Here's how.

[NOTE: I've tested this method successfully in the "Big Sur" and "Catalina" versions of macOS.]


Easy way: the "defaults" command

Quit Mail.app if it's running, and then open Terminal and execute the following command:

defaults delete -app Mail MessageListFont

The next time you launch Mail, you'll find the message-list font has reverted to the system default. Enjoy!


A less elegant alternative, if needed

If for whatever reason the technique described above doesn't work — and you're desperate — you can try this "brute force" method instead.

Quit Mail.app if it's running, and then open the following file in a text editor (such as BBEdit):

~/Library/Containers/com.apple.mail/Data/Library/Preferences/com.apple.mail.plist

(To be extra-safe, make a backup of the original .plist file before editing it.)

Once open, find the "MessageListFont" key/value pair. It will look like this:

    <key>MessageListFont</key>
    <data>
    YnBsaXN0MDDUAQIDBAUGBwpYJHZlcnNpb25ZJGFyY2hpdmVyVCR0b3BYJG9iamVjdHMS
    AAGGoF8QD05TS2V5ZWRBcmNoaXZlctEICVRyb290gAGkCwwVFlUkbnVsbNQNDg8QERIT
    FFZOU1NpemVYTlNmRmxhZ3NWTlNOYW1lViRjbGFzcyNAKgAAAAAAABAQgAKAA1hUaG9u
    YnVyadIXGBkaWiRjbGFzc25hbWVYJGNsYXNzZXNWTlNGb250ohkbWE5TT2JqZWN0CBEa
    JCkyN0lMUVNYXmdud36FjpCSlJ2irba9wAAAAAAAAAEBAAAAAAAAABwAAAAAAAAAAAAA
    AAAAAADJ
    </data>

Delete the entire key/value pair, and then re-save the file. (If it seems you're not able to do this directly, try using "Save as…" to save the edited version "on top of" the original version, replacing it.)

The next time you launch Mail, you should find that the message-list font has reverted to the system default. Congrats!

7
  • I tried to accomplish the desired result using the defaults delete com.apple.mail MessageListFont command in Terminal, but for some reason the system claimed it couldn't find the "com.apple.mail" domain. Trying with "com.apple.mail-shared" didn't work, either. So… "brute force" to the rescue!
    – jdmc
    Aug 18 at 14:37
  • Because it's a Sandboxed app, use defaults delete -app Mail MessageListFont.
    – benwiggy
    Aug 18 at 16:06
  • @benwiggy That version didn't work for me, either, in Big Sur. I also tried supplying the full pathname to the plist file itself… still no workie. Even with a sudo boost. ¯\_(ツ)_/¯
    – jdmc
    Aug 18 at 16:23
  • @benwiggy Update: I tried the "-app" style again, and this time it worked. I'll update my answer, leaving the "brute force" method as a just-in-case alternative. Thanks!
    – jdmc
    Aug 18 at 16:33
  • 1
    In my experience, you will get the "Domain com.apple.mail does not exist" error if Terminal does not have "Full Disk Access". Go to System Preferences -> Security & Privacy -> Privacy -> Full Disk Access and make sure Terminal.app is checked. Oct 29 at 18:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .