2

A mac in my office is running Big Sur 11.4 on a 2017 iMac 27". The drive is using Fusion, with a 1TB HDD and an SSD cache.

Recently, there has been a prevalent problem of some text showing up as boxes with question marks inside.

Zoom Question Marks Email Question Marks

I have confirmed in Font Book that Helvetica & Helvetica Neue display in this manner, and all the other fonts displayed in Font Book are displaying proper characters.

When I validate these Helvetica fonts, it returns that there is a serious error and that I should not use the font. Unfortunately, this is a system font and is used by default in many places, including MS Office UI.

When it asks me to check the fonts to disable, if I check Helvetica I cannot proceed because the OK button is greyed out. If I try manually editing the font from terminal, such as the command sudo cp Helvetica.ttc corruptHelvetica.ttc the copy command fails saying invalid argument Helvetica.ttc. I assume that's because the font and/or system fonts folder is protected somehow. It's owned by root and in the user group wheel.

I have tried the common things found on google, such as Restore Standard Fonts, and restarting in safe mode I've deleted all fonts in Font Book and copied them over again from System fonts folder. I've tried the trial version of Font Doctor, and its scan doesn't return any errors.

From googling the issue, it would appear this is a problem in Big Sur itself, and so I thought I would try to apply the latest software update in the off chance the font issue would be resolved. However, when I try to update it fails. using the UI it just gives a generic error about making sure I have a stable internet connection, and when trying from terminal softwareupdate -i -a I get the following error:

Failed to download & prepare update: Error Domain=SUMacControllerError Code=7740
"[SUMacControllerErrorPrepareFailed=7740] Failed to perform Prepare operation:
[MobileSoftwareUpdateErrorDomain(MSU):MSU_ERR_FILESYSTEM_DOESNT_VERIFY(3)_1_NSPOSIXError
omain:22|FullReplacementRequired|]"
UserInfo={SUMacControllerErrorIndicationsSummary=|FullReplacementRequired|,
SUMacControllerErrorIndicationsMask=2, SUMacControllerErrorIndicationsDescription=->
Full replacement is required [as opposed to incremental patch].,
NSUnderlyingError=0x7fa385517c60 {Error Domain=MobileSoftwareUpdateErrorDomain Code=3
"'./System/Library/Fonts/Helvetica.ttc' did not verify and is not on the exception list."
UserInfo={target_update=20G95,
NSLocalizedDescription='./System/Library/Fonts/Helvetica.ttc' did not verify and is not
on the exception list., NSUnderlyingError=0x7fa385516310 {Error Domain=NSPOSIXErrorDomain
Code=22 "Invalid argument" UserInfo
{NSLocalizedDescription=_alsr_safe_BOMCRC32ForFile("/System/Volumes/Update/mnt1/System/Li
brary/Fonts/Helvetica.ttc", ...) failed. errno=22}}, MSUFullReplacementRecommened=true}},
NSDebugDescription=[SUMacControllerErrorPrepareFailed=7740] Failed to perform Prepare
operation
[MobileSoftwareUpdateErrorDomain(MSU):MSU_ERR_FILESYSTEM_DOESNT_VERIFY(3)_1_NSPOSIXError
omain:22|FullReplacementRequired|], NSLocalizedDescription=Failed to prepare the software
update. Please try again.}

So it seems like I have a catch 22 here. I can't update, and I can't fix the broken fonts. All I want to do is fix the broken fonts so any suggestions or workarounds are much appreciated.

3
  • community.adobe.com/t5/photoshop-ecosystem/… maybe this will help
    – Berk Ilgar
    Commented Aug 13, 2021 at 16:52
  • @BerkIlgar Sorry, this does not help. My issue is not with Adobe fonts, my issue is with a corrupt system font in Big Sur which cannot be altered, nor can I install the latest software update for Big Sur. The article you linked deals exclusively with fixing the Adobe font Helvetica.
    – TLC
    Commented Aug 13, 2021 at 17:42
  • 1
    I'd run a repair install from Recovery - that ought to overwrite the bad file[s]. Last resort, nuke & pave, then migrate back [though I'd swap in an SSD while you're at it.]
    – Tetsujin
    Commented Aug 13, 2021 at 17:59

1 Answer 1

1

It's unlikely that the font files themselves are 'broken': it's probably just a corrupt font cache.

You can fix this easily by booting to Safe Boot mode (holding down Shift at restart), which will empty the cache. Then restart normally.

Or you can use the Terminal command:

sudo atsutil databases -remove

and then restart.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .