4

I have a MX Master 2S paired to a MacBook Air 8/8 16gb 512SSD on macOS Big Sur 11.4.

I came from Windows for the past 20 years. This is my first Mac. I used the Logitech Options software to change the scroll pattern and configure the buttons. It works as intended until it stops working. The only thing that fixes it for me is restarting the MacBook. It's very annoying have to restart sometimes two times a day, especially in the middle of a busy work day.

Sometimes the scroll wheel stops working totally. I try killing the Logitech Options daemon process but that doesn't solve anything. I never had any issue with this mouse connected to my Surface devices.

I'm ready to pull my hair out and open to solutions.

(I've tired deleting Logitech Options and installing it again.)

2
  • Try deleting logi options and run without it. What issues do you need to fix after that
    – mmmmmm
    Jul 10, 2021 at 13:11
  • @mmmmmm, without the logi options software I'm unable to configure the options for the buttons and side scroll wheel.
    – JAL
    Jul 12, 2021 at 12:32

5 Answers 5

3

I ran into same issue since a few days with my Mm M1 and a MX 2s. The wheel stopped working after few hours and only a restart helped as the accessibility was already granted in the system settings.

Currently I run a looooong taking TM backup and not wanted to restart the machine. So I looked into the running processes and searched for the Logi daemon and killed it. As it is (obviously) configured with the restart flag in launchd it restarts immediately and the wheel works fine again:

ps aux |grep -i LogiMgr
che   3112   0,4  0,3 35519872  53716   ??  S     4:54pm   0:07.08 /Applications/Logi Options.app/Contents/Support/LogiMgrDaemon.app/Contents/MacOS/LogiMgrDaemon --launchd

Simply kill this now:

# be sure to take the correct PID
sudo kill -9 3112

After this the daemon starts immediately and the wheel works fine:

ps aux |grep -i LogiMgr
che   3196   0,2  0,3 35539324  52984   ??  S     5:04pm   0:01.41 /Applications/Logi Options.app/Contents/Support/LogiMgrDaemon.app/Contents/MacOS/LogiMgrDaemon --launchd
2

I started experiencing issues on macOS Big Sur. I really only noticed on 11.5.2 since I didn't have my mouse with me on earlier versions.

I discovered you need to, in System Preferences > Security & Privacy > Accessibility, enable Logitech Options Daemon and Logitech Options to have access.

I previously only had the Daemon enabled and once I enabled Logitech Options as well it started working again.

1
  • Thanks, enabling both fixed the issue for me too
    – Steve C
    Aug 26, 2021 at 4:14
0

Hold Option+Shift and click on the menubar Bluetooth icon or Bluetooth icon inside Control Center. There should be a couple options that are not normally displayed:

Reset the Bluetooth Module Factory Reset all Apple Devices (won't work with Logitech)

Then optionally remove the Logitech device and re-pair it.

6
  • The MX Master 2 doesn't run off the Apple Bluetooth, it has its own USB dongle. I'd suspect it's too far away from the mouse. I plug mine into the keyboard to keep it close.
    – Tetsujin
    Jul 11, 2021 at 13:22
  • @Tetsujin mI'm not using the dongle, it's connected directly to the laptop bluetooth. The mouse is right next to the laptop.
    – JAL
    Jul 12, 2021 at 12:29
  • @Tetsujin The Logitech MX Master 2s supports both Bluetooth & the Logitech dongle. Jul 12, 2021 at 15:02
  • Yeah, so I discovered. I've no clue then, I've never run one straight off BT, only off the dongle. I've had one for the past 3 years or so, never had it drop out once.
    – Tetsujin
    Jul 12, 2021 at 15:24
  • @JamesBrickley Today my laptop was asleep longer than usual with my mouse disconnected. When it woke up it wouldn't function correctly. I tried the steps mentioned above and decided to add in uninstalling the Logi Options software. With the mouse connected and software reinstalled, logi options is not detecting the mouse. You can see a screenshot here : 1drv.ms/u/s!AjGXVzekDHBboMcYpuycLslMOlNDlg?e=dFaM05 I'm 100% certain if i reboot it will be displayed in Logi Options but unfortunately I can't afford to reboot right now.Maybe in about 12 hours I can reboot.
    – JAL
    Jul 15, 2021 at 1:10
0

Updating to big sur 11.5 seemed to have fixed this for me. Since the update about a week ago I haven't had any issues with my MX Master 2s

0

I don't know if we have the same problem because I have an MX Master 3, but using the USB instead of Bluetooth fixed it for me.

Also, I haven't been experiencing those problems ever since I switched to the macOS 12 Beta.

1
  • I lost the USB dongle :(
    – JAL
    Aug 26, 2021 at 2:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .