Ok, I have an issue that I absolutely cannot figure out.

When I use my mouse on my Mac every few minutes. The mouse freezes for a moment, seems to restart, then allows control again. The issue affects every button, scroll, and pointer movement.

I've tried using bluetooth as well as the supplied dongle.

The error doesn't seem to affect any other bluetooth or wifi connections to my Mac, only my mouse.

I tried uninstalling Logitech Options+ to see if that was the issue and nope, still happens.

I get the following errors in console when it freezes:

error   08:47:39.015479-0400    bluetoothd  Invalid operation. Trying to get HIDBehavior for 27F98F35
error   08:47:39.015886-0400    bluetoothd  Invalid operation. Trying to get HIDBehavior for EE502172
error   08:47:39.016387-0400    bluetoothd  Invalid operation. Trying to get HIDBehavior for 35789670

This is what comes up right before the error in Console:

default 08:47:39.015161-0400    bluetoothd  Update devices: paired, classic, 5 total
default 08:47:39.013889-0400    bluetoothd  Accessory power changed (coalesced)
default 08:47:38.023031-0400    bluetoothd  Sending XPC message "CBMsgIdPeerConnectionParametersUpdated" to session "com.apple.PerfPowerServices-central-525-29"
default 08:47:38.016076-0400    bluetoothd  Connection Update: setting LE device "<private>" connection threshold to 50 events with interval 12, LSTO 100

I've reset PRAM and SMC to no avail. I've charged batteries, un-paired and re-paired, and just about everything else I can think of. I even wiped and reinstalled MacOS.

So my question is this: What in blazes is causing my mouse to behave this way? And more importantly, how do I fix it?

I have tried the following mice and each has had the same issue:

  • Logitech MX Master
  • MX Master 2
  • MX Master 3 for Mac
  • PC/Mac MX Master 3s

I've run each one on my 2019 MacBook Pro with Touch Bar. Here's the specs:

  • Monterey 12.4
  • 13-inch 2019 w/2 Thunderbolt 3 ports
  • 1.4 GHz quad-core Intel Core i5
  • 16 GB ram

Here's my Bluetooth info: Bluetooth Controller:

  • Address: F8:FF:C2:5B:CE:D1
  • State: On
  • Chipset: BCM_4377
  • Discoverable: Off
  • Firmware Version: 85.87.148
  • Product ID: 0x0001
  • Supported services: 0x382039 < HFP AVRCP A2DP HID Braille AACP GATT Serial >
  • Transport: PCIe
  • Vendor ID: 0x004C (Apple)
  • Same problem here. Brand new Macbook Pro and MX Master 3S. The mouse works perfectly with Windows.
    – Tim
    Commented Feb 12 at 10:29

3 Answers 3


They seem to easily suffer EMF interference, or just plain ol' stuff in the way or too far to reach properly.

My unifying dongle is currently plugged into the USB2 socket directly under my keyboard to keep it near & dear. Another one I have on a USB extender cable running to underneath my sofa, for the Mac I use to watch TV on. The third, an older type with its own little stand, was lifted up to sit under the monitor, again as close to the mouse as we could get. Different Logitech types, only one is an MX, but all similar in behaviour. All used to get the hiccups before we took this remedial action.

I also very occasionally notice Options seems to forget it's running & consequently my programmed actions fail until I re-open the control app, but this doesn't seem related.

  • I have had very similar experiences. I am very frustrated that these problems persist in these days, but on the other hand happy about the Unifying dongle.
    – X_841
    Commented Jul 19, 2022 at 16:57
  • I'm within 1 ft clear site of my Mac and the dongle, so I don't even know.
    – beervenger
    Commented Jul 19, 2022 at 19:36

I have the same issue on my MX Master 3S on both Linux Debian 11 and Windows 10. I called Logitech tech support and they decided to replace via warranty after I explained the issue regardless of even having options installed. The replacement device will be here later this week.

  • 1
    Please update the answer once the replacement device arrives.
    – nohillside
    Commented Sep 13, 2022 at 3:31

Ok, so this doesn't seem to make much sense, but oddly enough, the only way to get the MX Master 3S to work smoothly on a new M2 MBP, was to also connect the USB cable, while using the mouse in Bluetooth mode through the dongle that came with it.

For some reason, macOS stubbornly refuses to accept the MX Master 3S if it's only connected by USB. Same is the case when trying to connect through Bluetooth directly - i.e. without Logitech's dongle. In both cases, the mouse isn't recognized.

Beside that, neither disabling "Allow Handoff between this Mac and your iCloud devices" in System Preferences->General, nor installing Logi Options+ had any (noticeable) effect.

The fact that the mouse is working flawlessly on both Ubuntu and Windows indicates that this is a macOS issue.

  • Well, I'm still having this issue so I broke down and started using the USB dongle that came with the mouse. Not optimal since my Mac has USB-C, but it works fine when I'm docked.
    – beervenger
    Commented Sep 15, 2022 at 12:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .