3

My G613 Logitech Keyboard connects to my MBP correctly at first. The MacBook ask for a pin code, the keyboard is working and it works without any problems.

As soon as I power off the keyboard just one time, or put the MacBook to sleep, the keyboard stops working. However, it still shows as connected in the Bluetooth device list.

G613 in Bluetooth menu

Some informations :

  • Keyboard works perfectly on another PC
  • Macbook is on Catarina, last available update.
  • Catarina is an update, not preinstalled
  • Keyboard worked before, can't remember if on catalina or not
  • Tried a SMC reset
  • Tried reinit Bluetooth module (shit+option on Bluetooth icon > Debug)
9
  • Are you on Mojave or Catalina? If the latter, did your Mac come with it preinstalled or did you upgrade? Did it ever work or is this a brand new keyboard that's giving you issues? Did you contact Logitech support for any info? – Allan Feb 1 '20 at 17:33
  • @Allan I added some informations in the post. – iizno Feb 1 '20 at 19:02
  • So what I'm gathering is that you're on Catalina now, but you were one Mojave (or earlier) prior. The keyboard was working, but you can't pin point when. As for Catalina, did you upgrade in place or did you do a clean install (meaning you wiped the drive first)? Try booting in Safe Mode (hold shift while booting). If you upgraded from something to Catalina, try downgrading by installing a previous version (Mojave most likely) to a USB flash drive and boot from that. If the issue goes away, you've at least narrowed it down. – Allan Feb 2 '20 at 0:39
  • I can't really downgrade. This is my work's MBP. I will try a SMC reset. – iizno Feb 2 '20 at 17:24
  • I tried to SMC reset, no changes. – iizno Feb 2 '20 at 17:30
3

I faced exact same problem. This worked for me :

press and hold the Bluetooth button in the g613 keyboard until it starts blinking faster.

On Mac, do the BlueTooth connection as explained by @Vadim Flaks, once connected you can remove the old G613 from your BlueTooth settings ( which is now disconnected )

2

I wish I knew of a way to make this problem go away completely, but the best I can give you is a workaround:

  1. in the Bluetooth menu hit the "X" button to remove G613 from the list of connected devices
  2. hit the connect to "Bluetooth" button on the keyboard again to make G613 discoverable.
  3. when the keyboard shows up in the bluetooth menu hit "Connect" and punch in the PIN as asked
  4. You're back in business until the next connection interrupt. Rinse and repeat.

This, along with the useless and annoying macro keys, really makes me wish I went with something else for my wireless keyboard.

0

I had the exact same issue, combined with the fact that the Logitech G Hub for Mac would never recognize that the keyboard was connected to the system.

The solution I found works if you have a docking station or other connector with a regular USB port. In the battery compartment of the keyboard is a USB dongle already paired with this keyboard, and it works better than a plain Bluetooth connection.

  1. Go to the System Preferences -> Bluetooth and make sure the keyboard is not connected. If it is listed in the devices, click the little "x" icon to remove it.
  2. Plug the dongle in to your docking station.
  3. Press the button on the keyboard that looks like a Wifi signal. The keyboard should connect. If you have G Hub installed, it should show up there, and you will be able to configure the keyboard as well.

The only problem I've had with this is that I had to use the System Preferences -> Keyboard to re-map Command and Option so that "Alt" becomes the Command key and Windows becomes Option. This matches the key positions on the native Mac keyboard, and is purely a matter of taste.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .