1

A couple of weeks ago I damaged the logicboard of my MacBook when I attempted to clean the keyboard. However, it worked perfectly fine if I had the lid closed and attached it to an external keyboard. But it happened twice, that there was a triple klick sound from the MacBook internal speakers and my Bluetooth keyboard stopped working. I figured out that only a restart could fix the problem.

Now, I got a new MacBook and transferred the system from the old one. Now it gets weird: the same strange clicking sound and the in-built keyboard stops responding. However only letters seem to be affected. Now I am wondering if it is a software issue that I carried over via the system transfer. Any ideas?

1
+50

Did you have a Logitech keyboard at one time? If so, you might have an old Logitech kernel extension that is causing problems. Uninstall the Logitech control panel from System Preferences and look in /System/Library/Extensions and delete LogitechHIDDevices.kext and LogitechUnifying.kext (reboot for extra certainty). Many people have had problems due to the Logitech stuff on Mountain Lion.

If that's not it, your problem still could be caused by something similar. Third-party kernel extensions are transferred during a system migration. Likewise it could be a more run-of-the-mill extension conflict.

  • 1
    usboverdrive.com/USBOverdrive/Support.html has a list of other keyboard drivers, and you can also use Consultant's Canary to get a list of kernel extensions that were not preinstalled. – Lri Apr 30 '13 at 7:06
  • sorry, I forgot to mention it in my post, I have the original Apple Bluetooth keyboard. But the problem also appeared when I was using the laptop keyboard when the external keyboard was turned off. It happens every 2-3 days. Login out and in solves the problem, though. But it is annoying still. – bluewoodtree Apr 30 '13 at 18:06
  • The part Third-part kernel extensions are transferred during a system migration. sounds to be very promising. So how could I avoid that? could re-installing mountain lion solve the problem when I only transfer my data from the TimeMachine backup and not the previous settings and programs? – bluewoodtree May 2 '13 at 19:33
  • @blue, yes, if you do not transfer settings or programs then you will avoid transferring kernel modules. Or course, that means building a new system from scratch... – Old Pro May 2 '13 at 20:48
  • Thanks. If this is what it takes I think I will do that some time. – bluewoodtree May 3 '13 at 4:16
2

I had some similar issues with USB keyboards attached to an iMac. I solved this issue by deleting the contents of the Library/Caches folder from my user session (the Home icon) and rebooting the Mac.

  • Thanks, restarting did it for me, however, the problem occurs once per week or so. I followed your advice cleaning the cache folder and will see if how it goes now – bluewoodtree Apr 24 '13 at 19:15
  • I further emptied PRAM and SMC, but unfortunately, a few days later the problem occurred again...that's really weird. – bluewoodtree Apr 26 '13 at 5:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .