2

Update Dec 3: I keep experiencing this issue whenever there's little memory left. I.e., Bluetooth audio stops behaving correctly whenever Memory Pressure in Activity Monitor is high; the only way to get it working again afterwards is to disable and re-enable Bluetooth.

When I connect an audio device and use it to play music, audio stops working after a few minutes and switches to internal speakers instead (but the device continues to be shown as "Connected" in Bluetooth). This happens with all my Bluetooth audio devices (3 in total). I don't experience any of these issues when using the same devices with my smartphone. The issue started around a month ago, roughly at the time when I upgraded to macOS Catalina. I'm using a MacBook Pro (Retina, 13-inch, Early 2015).

I have tried the following steps already:

  • Moving my bluetooth device right next to my laptop
  • Updating to macOS Catalina 10.15.1
  • Disabling and enabling Bluetooth
  • Restarting the laptop
  • Removing and re-adding all Bluetooth devices
  • Deleting the file "com.apple.Bluetooth.plist" in /Library/Preferences/
  • Resetting PRAM
  • Searching StackExchange and the internet for more advice

None of these have helped, not even temporarily.

This is what it looks like when the issue is present:

enter image description here

When hovering over the audio device, its name disappears; when clicking it, the audio menu bar icon becomes animated and looks like it's searching/loading in a way I haven't seen before.

At the same time, the device looks normal in Bluetooth:

enter image description here

enter image description here

I'd greatly appreciate any help!

1

I tried a whole bunch of additional things that are related to sound rather than bluetooth. The issue is now resolved. I don't know which of the steps fixed it but if you have the same issue, doing all of them will likely resolve it:

1. Reload coreaudiod

Enter the following into Terminal:

sudo killall coreaudiod
sudo launchctl unload /System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist
sudo launchctl load /System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist

Then restart the laptop (or do step 3 (below) at the same time).

I got errors when doing the above, but perhaps it still helped somehow.

2. Unload the kernel extension

sudo kextunload /System/Library/Extensions/AppleHDA.kext 
sudo kextload /System/Library/Extensions/AppleHDA.kext

Again, I got errors when doing the above, but perhaps it still helped somehow.

3. Reset the SMC

Shut down the laptop, connect it to power, hold the four buttons cmd-option-shift-power for at least 10 seconds, release, start the laptop again.

--

After performing these steps, everything was back to normal.

| improve this answer | |
  • Update: The issues just started occurring again, so it seems like this isn't a permanent fix. – Jonas Nov 27 '19 at 9:44
  • Update Dec 3: I keep experiencing this issue whenever there's little memory left. I.e., Bluetooth audio stops behaving correctly whenever Memory Pressure in Activity Monitor is high; the only way to get it working again afterwards is to disable and re-enable Bluetooth. – Jonas Dec 3 '19 at 11:07
  • This should be fixed in macOS 10.15.3 discussions.apple.com/thread/251061620 – Quisse Mar 2 at 13:26
  • Cool, thanks. I noticed the issue occurs whenever there's a lot of memory pressure. I ended up buying a new laptop with 4x as much RAM partly because of this issue, but glad to hear it's now fixed on the software side. – Jonas Mar 3 at 15:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .