6

I plugged in a USB Bluetooth dongle into my MacBook Pro 16" late 2019 model and it seems that after unplugging the dongle I am unable to use my Macbook's internal Bluetooth controller. I am not able to connect to any BT device when the dongle is not connected to the Macbook.

Here is my System Report for Bluetooth:

  Apple Bluetooth Software Version: 7.0.4f6
  Hardware, Features and Settings:
  Name: Aleksanteri’s MacBook Pro
  Address:  3C-22-FB-05-56-D9
  Bluetooth Low Energy Supported:   Yes
  Handoff Supported:    Yes
  Instant Hot Spot Supported:   Yes
  Manufacturer: Broadcom
  Transport:    UART
  Chipset:  4364B3
  Firmware Version: v50 c4177
  Bluetooth Power:  On
  Discoverable: On
  Connectable:  Yes
  Auto Seek Pointing:   On
  Remote wake:  On
  Vendor ID:    0x05AC
  Product ID:   0x0096
  Bluetooth Core Spec:  5.0 (0x9)
  HCI Revision: 0x1051
  LMP Version:  5.0 (0x9)
  LMP Subversion:   0x2032
  Device Type (Major):  Computer
  Device Type (Complete):   Mac Portable
  Composite Class Of Device:    0x38010C
  Device Class (Major): 0x01
  Device Class (Minor): 0x03
  Service Class:    0x1C0
  Auto Seek Keyboard:   On
  Devices (Paired, Configured, etc.):
  Magic Trackpad 2:
  Address:  E4-50-EB-F1-5F-81
  Major Type:   Peripheral
  Minor Type:   Trackpad
  Services: 
  Paired:   Yes
  Configured:   Yes
  Connected:    No
  Bluetooth Core Spec:  1.0b
  Vendor ID:    0x004C
  Product ID:   0x0265
  Class of Device:  0x05 0x25 0x2594
  Services:
  Bluetooth File Transfer:
  Folder other devices can browse:  ~/Public
  When receiving items: Accept all without warning
  State:    Disabled
  Bluetooth File Exchange:
  Folder for accepted items:    ~/Downloads
  When other items are accepted:    Save to location
  When receiving items: Accept all without warning
  State:    Disabled
  Bluetooth Internet Sharing:
  State:    Disabled
  Incoming Serial Ports:
  Bluetooth-Incoming-Port:
  RFCOMM Channel:   3
  Requires Authentication:  No

What have I tried to do to fix this:

  • Restarted the computer numerous times
  • Deleted /Library/Preferences/com.apple.Bluetooth.plist file
  • Reset PRAM, NVRAM and SMC
  • Ran bluetooth with Debug mode to "Reset Bluetooth Module" and "Remove all devices"
  • Installed Bluetooth Explorer that shows the following error on startup:
updateChainPower error: -3903
2020-04-13 20:35:57 +0000 Apple80211Get(APPLE80211_IOC_BTCOEX_MODE) returned error -3903
updateChainPower error: -3903

Bluetooth starts working again when I plug in the dongle. Have I broken the internal controller by attaching an adapter to the machine? I am not even able to connect my Magic Trackpad to the Macbook via Bluetooth. First, I pair it with the machine using the cable. After disconnecting, it is unresponsive and is not able to connect.

What are my next steps? Is this a warranty issue?

EDIT: This is the dongle that might have caused the issue: https://www.aliexpress.com/item/32686102148.html

EDIT2: Took it to the repair shop today, I'll follow up with what was the resolution of that case.

Strangely enough, they advertise that it does not work with Macs but now it is the only way to get Bluetooth working on the Macbook.

8
  • 1
    For completeness, would you add the manufacturer and model number of the BT dongle that caused the problem, please?
    – IconDaemon
    Commented Apr 13, 2020 at 20:57
  • @IconDaemon Good point, added
    – rnli
    Commented Apr 13, 2020 at 21:41
  • Curious...the 2019 MBP has one of the latest BT adapters, why would you need a BT dongle? Was the internal one giving you issues?
    – Allan
    Commented Apr 14, 2020 at 2:33
  • @Allan It was working fine but I needed to test if the dongle was broken or not. It was having issues connected to my PC so I connected it with my Mac to see if there are any issues
    – rnli
    Commented Apr 14, 2020 at 5:08
  • Get a 32GB Flash Drive (or a regular USB HDD) and install a fresh copy of macOS to that, then boot off of it (hold Opt to load the boot manager). See if Bluetooth works
    – Allan
    Commented Apr 14, 2020 at 14:33

5 Answers 5

5

This seems to be a general problem with motherboards of 2019 models.

Check this link: https://discussions.apple.com/thread/250944058

There are many people including myself that has this problem.

It seems like the only resolution to the problem is a motherboard replacement.

I have exactly the same error and problem.

I used a dongle that supports mac.

Just for information: I have tried to reinstall, clear t2 chip using xartutil --clear-all, nvram reset, smc reset and so on.

Seems motherboard replacement is the only resolution.

Update: A new method to fix this problem has been revealed on the apple forums: https://discussions.apple.com/thread/250944058

6
  • The AirPort adapter has both the the WiFi and Bluetooth radios in one unit and it’s not soldered to the board, just replace that, but I doubt that’s the solution
    – Allan
    Commented Apr 14, 2020 at 14:29
  • Good thing that I have the warranty still in place. Took it to the repair shop today, I'll follow up with what was the resolution of that case. They threatened to bill me 90€ in case of unnecessary check-up.
    – rnli
    Commented Apr 14, 2020 at 16:36
  • 1
    @mil - before you do that - see my comment re: installing/booting from external drive. Don't pay $$ when this is likely what Apple will do - reinstall your OS.
    – Allan
    Commented Apr 14, 2020 at 16:42
  • 1
    update: A method to fix this problem has been revealed in the apple forums. discussions.apple.com/thread/250944058
    – Jorgen S.
    Commented Aug 7, 2020 at 9:59
  • 1
    Thanks for coming back and updating your answer with the new info!
    – fsb
    Commented Aug 7, 2020 at 15:12
2

In my case, the answer was to replace the whole motherboard along with all the internals as they are glued to the laptop. This includes CPU, GPU, SSD and other expensive components. What a waste just because of a small BT chip is dead.

The company doing the maintenance told that they were unable to detect anything was wrong using their tests, but could not get the BT working. Glad it fell under warranty.

2

I have been able to solve this exact problem by:

  1. Shutdown the Mac completely
  2. Plugin any supported usb bluetooth dongle while Mac is off
  3. Start the Mac and login to the system
  4. Use bluetooth to find and connect to some bluetooth device (propably optional step)
  5. Remove the usb bluetooth dongle
  6. Internal bluetooth started to work again normally

Also if this doesn't work first time you might want to repeat few times and try combinations where you shutdown the Mac with and without the dongle and startup the same way with and without the dongle.

--

Before this I also did following:

  • Reset NVRAM
  • Reset SMC
  • Reset the bluetooth module
  • Remove bluetooth.plist
  • Used bluetooth explorer.app
  • Booted to recovery (CMD+R) on startup

--

I think this is some kind of firmware related problem where call to re-enable internal bluetooth is not executed properly in certain situations leaving the bluetooth in unusable state.

Solution in my case was insipired by similar headphone jack problems on older models where Mac thought that jack was plugged in and disabled onboard speakers even if no jack was connected.

3
  • In same situation & hoping to avoid MB replacement. Can you share which Mac model you were using? Was the dongle connected via a hub or USB A-> USB C adapter?
    – gojomo
    Commented Aug 6, 2020 at 20:10
  • From the longer threads here – discussions.apple.com/thread/250944058 – it seems a key is to use an older Bluetooth-2.0 dongle, that somehow does the offboard activation/deactivation better than the particular Bluetooth 4.0/4.1 dongles (typically using "Cambridge Silicon Radio" chips) that trigger the problem.
    – gojomo
    Commented Aug 11, 2020 at 2:43
  • Thank you! This (nicely simple) solution worked for me after 2 attempts, and I did not even shut down at any point. I used a BT 4 dongle labeled "CSR 4.0", and after plugging it in, connected to an Apple Magic keyboard I had laying around. After unplugging the dongle, the keyboard remained connected, and other devices could connect again.
    – Tommy
    Commented Nov 22, 2020 at 8:56
1

I have the same problem with my MacBook Pro 2019 16". I've connected a BT dongle via an USB-C hub for testing purposes. Without the USB BT dongle, I can't connect to BT devices. Interesting fact: the USB Dongle is the only controller that is available within th Apple Bluetooth Explorer Utility.

enter image description here

3
  • But it adds information and confirms the original question so I see value in this
    – rnli
    Commented Apr 19, 2020 at 11:45
  • having the same issue. Also Cambridge Silicon Radio BT dongle. if not attached, i only see "none" in this list. Same error in Event Log.
    – Tobi
    Commented Jun 8, 2020 at 12:49
  • same problem here Commented Aug 26, 2020 at 7:05
0

I have MacBookPro 16 from 2020. In my case non of those tips helped. However installing backup from Time Machine (before attaching dongle) solved issue.

EDIT:

It stopped working after a few hours.

Fresh install did not help. Apple has replaced whole main board.

I did not try latest tip because I've got replacement already, but I think it's worth trying: sudo nvram bluetoothHostControllerSwitchBehavior="never" from https://discussions.apple.com/thread/250944058

1
  • Did you try reinstall the OS too before using time machine? My issue seemed to be caused by malfunctioning hardware.
    – rnli
    Commented Nov 19, 2020 at 9:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .