1

My Mac crashes somewhere between once per day and once per week, when I have too many applications open. When I start it again, then I'm unable to scroll up, on my external Logitech Mouse. Scrolling down keeps working - it's just scrolling up.

I can get it to work again, by rebooting my machine and clearing the PRAM (holding down CMD + Option + P + R upon startup). So I'm pretty certain, that it's a software-issue.
However once, I got it working by simply reboot. And another time I tried that the clearing of the PRAM didn't solve it. But then I did it again, which then solved it. Really wierd!

Here are some facts:

  • It has happened about 20+ times so far, and it's always scroll-up that won't work.
  • It's not every time it crashes, but I'd say 80% of the times. My gut feeling tells me that it has something to do with, if I have been scrolling, when it crashes.
  • I have tried several different mice-models, and this is the only model it has happened with. But I don't want to switch mouse-model, since this is the best mouse across all other areas.
  • The built-in touch mouse works as it should. It's only my external mouse (the scroll-up feature) that doesn't work.
  • I've tried reconnecting the USB-cable. And the USB-cable is connected to an adapter, and I've tried reconnecting that as well.

I'm looking for a way where I can 'clear the driver cache' for the mouse? Are there any such thing?


System specs:
Mac OS: Catalina, 10.15.6
MacBook Pro (15-inch, 2016)


Update1 - 2020-11-15

I just discovered that it happens with the the Mx Anywhere 2s Logitech mouse as well.


Update2 - 2021-04-06

Okay. The bug went away for a good amount of time, after having followed the steps from my posted . For months, I didn't experience the bug at all.

I then switched computer, where I used Mac's Migration Assistent to move all my files and setup to the new machine.

After a while, the bug returned once. But a simple restart solved it (no resetting PRAM and/or NVRAM. Just a simple restart.

But then the bug returned just now. I had my M110-mouse plugged into my docking station (Hyper Gen2 dock). And regardless of what I did, I couldn't get the scroll to work again. I tried:

  • Rebooting
  • Rebooting and resetting PRAM and NVRAM
  • Running this in the terminal: sudo kextunload IOUSBMassStorageClass.kext
  • Running this in the terminal: sudo kextload /System/Library/Extensions/IOUSBMassStorageClass.kext
  • Unplugging mouse, rebooting, plugging in mouse again.
  • Plugging in another mouse of the same model (!?)
  • Clearing cache and temporary files using CleanMyMac
  • Reinstalling Logitech Options
  • Ensuring that the Logitech Options and Logitech Options Daemon had Accessibility-access in 'System Preferences' >> 'Security & Privacy' >> 'Privacy' >> 'Accessibility'.

And nothing changed... The only thing I didn't try was a different USB-adapter / dock.

The wierd thing was that, if I rebootet my computer, then while windows was reopening, then I WAS ABLE TO SCROLL UP!? ... But once everything had started up, scroll up stopped working. So it is some software bug.

I tried plugging in my Magic Mouse 2, and on that the scroll did work!

I'm not a fan of that mouse, so I went and bough a new mouse that was bluetooth (MX Anywhere 3). That worked as well.

So it must be something with the dock - or that model of Logitech Mouse.


Update 3 - 2021-05-02

Okay. This has gone on for WAY TO FRICKING LONG NOW!!!

I've now ditched the docks, but I still get the error.

I have gotten the error on:

  • 2 different computers
  • 3 different mice (MX Anywhere 2 and two different M110 Silent Mouse)
  • using 2 different docks
  • using all kinds of different Logitech Helper Software
  • using both the USB driver and direct Bluetooth connection

The new discovery was, that if I removed the mouse in Bluetooth settings and reconnected it, then I got it working without restarting. But only once! Second time I did it, no luck. I tried several times, but it was only that first time that I got it working. And that was on the MX Anywhere 2 mouse.

I've also purchased an MX Anywhere 3 mouse - and I don't recall having gotten the bug on that, but I'm not sure.

This is driving me mental.


Update 4 - 2021-05-09

I just experienced something wierd. The bug came back after I woke my machine up from sleep (how it does every now and then).

I then went to the kitchen to get a cup of coffee. When I returned, then the mouse worked!

The bug was in Google Chrome - Canary, with my Logitech Anywhere MX2-mouse.

1
  • What makes you think that something called "the driver cache" is at fault? If that is the only mouse it happens with it is more likely to be a problem (hardware) with the mouse itself. – Steve Chambers Nov 30 '20 at 22:30
0

I just got it working with the Mx Anywhere 2s mouse without rebooting (!), by first uninstalling:

  • Logitech Control Center
  • Logitech Options
  • Logitech Unifying Software

And afterwards installing only Logitech Options again. By the way, I used CleanMyMac to uninstall the application and preference panes, since Logitech drizzle them all over your Mac.

Please note that this is a solution up until Update1. I didn't solve the issue described from Update2.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .