24

Before Sonoma, pressing Ctrl+⌘+Space would bring up the emoji Input Method Editor

enter image description here

But now, depending on the context, MacOS Sonoma will bring up a different editor. For example, if I type 'interesting ' and press Ctrl+⌘+Space I get this different UI

enter image description here

This inconsistent response to the same keypress is really unhelpful for me. I know exactly what state things are in when I get a consistent response.

The particular instance was me wanting to type something like

"I did this dumb thing because I thought it would be more interesting 😅

And the new feature guessed wrong (showing the 3 choices above) and so wasn't helpful. In fact it was worse than not helpful, it was actively in my way as I have to workaround it to get what I wanted.

Other examples include

I hope bug XXX will be fixed when we switch to Monorail

Where again I wanted 😅 but it unhelpfully picked 🚝

I'm pretty sure this will pass on the next run

Where I wanted 🤞 but it picked 🏃

Praying tomorrow is sunny

where I wanted 🙏 but it picked 🌞

Can you please check out the link above?

where I wanted 🙏 but it picked ⬆️

And many many more.

How do I turn off this new unhelpful "guess the emoji we think the user wants and show a different UI" feature of MacOS Sonoma?

3
  • 8
    Simple workaround is press spacebar twice while holding control and command keys pressed - "regular" pop-up window will be displayed. Commented Oct 8, 2023 at 4:30
  • 3
    I can also click the V at the end but I'm not looking for a workaround, I'm looking to stop this bad UX from appearing at all. Thanks for the keys though.
    – gman
    Commented Oct 8, 2023 at 5:47
  • 8
    @AivarPaalberg You have to wait to see if the mini menu popups up first, otherwise the double press hides it. eg. when the last word you've typed is "asd" the mini menu doesn't show up because there isn't a good emoji for "asd". Double tap hides the menu. It just means that you've got to wait a second to see which menu's popped up before typing to search or use a recent, etc. It's annoying AF. Commented Nov 8, 2023 at 18:12

2 Answers 2

3

To disable the smart emoji suggestions, run the following command in the Terminal app (your Mac's lock password will be required) and then restart your Mac:

sudo defaults write /Library/Preferences/FeatureFlags/Domain/UIKit.plist emoji_enhancements -dict-add Enabled -bool NO

And to re-enable this:

sudo defaults write /Library/Preferences/FeatureFlags/Domain/UIKit.plist emoji_enhancements -dict-add Enabled -bool YES

(source)

2
  • 1
    This is great news. Just tried it and it works.
    – stevec
    Commented May 20 at 0:02
  • Amazing! Worked for me! Thank you!! Commented May 22 at 5:40
1

This is a workaround, not a way to disable it. On your mac, you can set the function key to open that very menu. You can do this in System Settings and then to keyboard menu. There you should find a setting called "Press 🌐 to" and you can select "Show emojis & symbols".

2
  • Thanks for the suggestion. I'm a polyglot and actually use that key to switch input methods. I get your point though. I could pick some other key.
    – gman
    Commented Mar 7 at 23:35
  • @gman I think this doesn't solve the problem. Example: if I type "very happy", and hit 🌐 , it still makes suggestions (rather than displaying the menu) (i.e. it does exactly the same as typing "very happy" and pressing ctrl + command + space). (my 🌐 key was set to 'Show emojis & symbols')
    – stevec
    Commented Mar 9 at 10:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .