Since I updated to the new MacOS Sonoma when I am on YouTube and want to put in an emoji the function key with the round circles no longer works. It only brings up a very small square thing. I have to now touch that button twice for it to bring up the full emojis so I can select them. And sometimes even that doesn't work.

Stupid New Apple Emoji Popup Box

How do I change this and why on earth would Apple think it is a good idea to have that tiny pathetic pop up box where you cannot see anything?

  • 1
    What version specifically is "the new macOS Sonoma" you updated to. Bugs and issues can be introduced from one version to the next so knowing what version you're running is key to providing you with an answer. As for the "function key with the circles" do you mean the Fn/Globe key? Do you get the emoji picker when you press Ctrl-Cmd-Space?
    – Allan
    Commented May 18 at 14:15
  • 2
    YouTube app? YouTube in a browser window? Which browser?
    – IconDaemon
    Commented May 18 at 14:16
  • Only Youtube? Nowhere else? Commented May 18 at 15:40

1 Answer 1


To disable the smart emoji suggestions, run the following command in the Terminal app (your Mac's lock password will be required) and then restart your Mac:

sudo defaults write /Library/Preferences/FeatureFlags/Domain/UIKit.plist emoji_enhancements -dict-add Enabled -bool NO

And to re-enable this:

sudo defaults write /Library/Preferences/FeatureFlags/Domain/UIKit.plist emoji_enhancements -dict-add Enabled -bool YES


  • Would have been better if the author mentioned how they discovered this.
    – hym3242
    Commented May 20 at 1:50

Not the answer you're looking for? Browse other questions tagged .