0

I have set up a number of custom shortcuts for math/logic symbols to use in Word and OneNote, including the left/right arrow ↔. This works in OneNote, but I also need it to work in Word, but it keeps autocorrecting to the corresponding arrow emoji which is incredibly frustrating.

I have tried the following:

  • changing the shortcut to add a space after the ↔. This still corrects to the emoji.
  • selecting "change back to [custom shortcut]" – this does what it says, and corrects it all the way back to the shortcut, rather than to the arrow symbol I want
  • using the inbuilt shortcut \leftrightarrow (which I want to avoid because it's so much faster to type a three-character shortcut than that) also autocorrects to the emoji outside of math fields in Word
  • changing the shortcut trigger to something different. This still replaces the arrow with an emoji.

Within specified math fields, this issue doesn't occur, but I want to be able to continue to use these symbols outside of math fields, because that's the only way I can still use it within OneNote as well due to the way the Autocorrect dictionary for Office is set up.

I suspect that the issue is due to the fact that there is an inbuilt auto-replacement function for the arrow symbol to be replaced by the arrow emoji itself, much like how the smiley symbols started getting replaced by emoji a few years ago too, but I wouldn't know where to look to disable that to allow insertion of the actual arrow symbol itself. Any suggestions? Right now I'm copying and pasting but obviously this is not an ideal solution.

I am using Microsoft Word for Mac Version 16.46.

Thank you in advance, this is driving me up the wall!

4
  • 1
    If you select the emoji, what font is being used? Does changing the font fix it? Mar 14 at 0:36
  • Just a thought, what if you go into Preferences > Autocorrect (Outlook, Word might be different) and create exceptions for the text emoji you want to preserve... ? Mar 14 at 1:24
  • @TomGewecke legend!! That solves it – I have a custom default font in Word and inserting the symbol was making it automatically change to Apple Color Emoji, but when I change it to something like Arial or Cambria Math it seems to just insert the symbol. Thank you!
    – blue
    Mar 15 at 1:16
  • @SteveChambers I tried this out as well, but it didn't seem to work. Luckily Tom's solution seemed to work though, and since I don't mind just setting a different font when working with these symbols I think that's probably the solution I'll stick with. Thanks though, I appreciate it!
    – blue
    Mar 15 at 1:20
0

For some reason your Word would appear to be using Apple's Color Emoji font by default for symbols. Changing the font for them should fix it.

The representation of symbols as emoji or text can be a complex issue, see this document.

0

Go to Word -> Settings -> Autocorrect and do one of following:

  • Add an exception using the Exception button
  • Remove string to replace in the list below

Source: https://support.microsoft.com/en-us/office/autokorrigering-emojier-i-dokument-och-e-post-601cad94-1a54-41e2-8cf8-4b09a6eadfe1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .