9

I've recently upgraded to macOS Sonoma 14.0. Something that's driving me mad is this new emoji auto-replace suggestion menu.

Problem

Here's the message I'm trying to compose:

Happy birthday to our tree! ๐ŸŽ‰

Here's what macOS 14 wants me to write when I use the emoji shortcut:

Happy birthday to our tree! ๐ŸŒฒ

enter image description here

Question

How do I disable this smaller emoji suggester in favor of the traditional, full dialog?

enter image description here

Why?

In this author's opinion, emoji is punctuation, not a replacement for nouns. I use emoji to convey the emotion of the sentence, not make cute pictures of various nouns throughout. This smaller menu introduces another click and hasn't suggested the emoji I'd like to see once. ๐Ÿ˜–

2 Answers 2

5

According to Steve Troughton-Smith, this can be toggled using:

sudo defaults write /Library/Preferences/FeatureFlags/Domain/UIKit.plist emoji_enhancements -dict-add Enabled -bool NO
0

With the small dialog open, press the button(s) again to open the full dialog.

If you open the small dialog with the globe/fn key, press the key again.
If you open the small dialog with ctrl-cmd-space, press that key combination again.

Unfortunately, there appears to be no way to disable the small dialog from appearing first yet. This has also been asked on Reddit, see Is there a way to turn OFF the new emoji suggestions in Sonoma?.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .