6

A lot of emojis replace characters that I already use, usually imported from a symbol keyboard; but it doesn't mesh well with monospaced, small, or formatted text; for example, I like to flavor my documents with text art (art made (usually) from a monospaced font, and its characters).

Such characters include;↔↕↖↗↘↙➡⬅⬆⬇⚪⚫⬛⬜, in this case (on my end) some of them worked properly. the rate at which this happens is inconsistent, even in the same document!

  • You want to do this for things you are writing? Or for things others send to you? – GEdgar Apr 10 '15 at 18:44
  • 1
    You can disable the emoji keyboard, but emoji is essentially a font and iOS doesn't let you delete fonts. – Kevin Grabher Apr 10 '15 at 21:52
  • Receipients of your text may or may not see emojis, it depends on their device and what sort of fonts they have installed. – Tom Gewecke Apr 10 '15 at 22:33
3

Why do the same characters show up with a ‘text presentation’ in some situations and an ‘emoji presentation’ in others?

There is both a ‘text style’ and ‘emoji style’ for U+25B6 BLACK RIGHT-POINTING TRIANGLE (▶). Whichever style you get depends on whatever style the font you’re currently using has. For example, the font Apple Color Emoji has an ‘emoji style’ glyph for U+25B6 BLACK RIGHT-POINTING TRIANGLE while the font Lucida Grande has a ‘text style’ glyph for U+25B6 BLACK RIGHT-POINTING TRIANGLE. This is fine in a text editor, where you have control over whatever font you’re using for each character, but not in contexts where you don’t.

How can I specify whether or not I want the ‘text presentation’ or ‘emoji presentation’ for a codepoint in contexts where I have no control over the font?

The Unicode Consortium actually provided a solution for this issue in Unicode 6.1, detailed in this Unicode Technical Report.

Essentially, they’ve designated two codepoints as emoji variation selectors: U+FE0E VARIATION SELECTOR-15 (for a text presentation) and U+FE0F VARIATION SELECTOR-16 (for an emoji presentation).

Let me explain how they work. Whenever you enter one of those two variation selectors in a text field (whether through copy-pasting or other means), the text rendering system of your operating system—one conforming to the Unicode Standard, v6.1+—will change the glyph (through font substitution, if necessary) for the character immediately preceding the variation selector you just entered to one matching either ‘text style’ or ‘emoji style’ (depending on which variation selector you entered after the emoji).

Here’s a demonstration:

▶︎ (U+25B6 U+FE0E)

▶️ (U+25B6 U+FE0F)

For people viewing this page on older operating systems, I’ve included some images below demonstrating the behaviour in a normal text box on OS X v10.11 El Capitan.

The system font on OS X v10.11 (which is San Francisco), has no glyph for U+25B6 BLACK RIGHT-POINTING TRIANGLE, so OS X’s text rendering system automatically performs font substitution and ends up using the Lucida Grande UI font instead, which happens to have a 'text style' glyph for U+25B6:

Default Behaviour

Using U+FE0E VARIATION SELECTOR-15 immediately after it forces it to be ‘text style’, so the result is the same:

Text Presentation

Using U+FE0F VARIATION SELECTOR-16 immediately after it instead results in OS X’s text rendering system using a font with an ‘emoji style’ glyph for U+25B6 BLACK RIGHT-POINTING TRIANGLE instead, which happens to be the Apple Color Emoji font:

Emoji Presentation

(For the curious, the screenshots are showing the indispensable Split Up utility in UnicodeChecker).

|improve this answer|||||
  • This doesn't seem to work. On iOS, ︎ fails to prevent the emoji from being stylized. (💬︎ shows up stylized on iOS but not on other devices.) – Ryan Nov 17 '18 at 3:42
  • 1
    @Ryan The reason it’s not working for you with U+1F4AC SPEECH BALLOON is because Apple Color Emoji is the only font installed on iOS (by default) that contains a glyph for U+1F4AC SPEECH BALLOON in the first place. If there are no other fonts installed on your system that contain a glyph for the codepoint, no font substitution can occur. Here’s an example on OS X v10.11 El Capitan with the font substitution occurring. Keep in mind, the only reason it worked was because I already had the font Symbola installed. – アリスター Nov 21 '18 at 6:35
0

You can't. Emojis are part of iOS and can't be disabled.

|improve this answer|||||
0

Messages on the Mac has an option to not replace conventional smileys with emoji.

Edit > Substitutions > Emoji

I have this switched off on my Mac & if I type ;-) that's what is transmitted.
If I do the same on my iPhone, the same happens, only ;-) is transmitted & received.
I have no recollection of changing that behaviour on the phone, nor can I find any option that would let me - & changing it on the Mac doesn't appear to affect the phone.

Tom Gewecke is right, though, in so much as if the receiving device is not another iPhone, their device may auto-translate into emoji, over which you have no control.

The other thing is that you also have no control over what font is being used by the receiving device.

Having said all that, I was assuming you were talking about iMessage, but I realise that's not clear from your question. Maybe clarifying in which app you mean may change this & other answers.
Also, as far as I can see, none of those symbols you used are actually emoji, simply higher ascii or possibly unicode [I didn't check every one]

|improve this answer|||||
  • 1
    The problem is that various "ordinary" symbols going far beyond "smileys" are also displayed in "emoji" style by Apple's Color Emoji font. These are what the OP wants to have displayed in their ordinary style. – Tom Gewecke Apr 11 '15 at 13:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .