0

The Japanese input method has changed on my Mac. The traditional way on OSX and Windows is:

  1. type hiragana for the word;
  2. press space bar;
  3. use arrow keys to select (kanji + okurigana);
  4. press enter.

Somehow, (95% sure this because of El Capitan) my input method has become:

  1. start typing hiragana;
  2. while still typing hiragana, it continues to take heuristic guesses at the (kanji + okurigana) that I might want. This approach makes most sense on mobile phones, but I don't want to do this on my MacBook!
  3. pressing esc reverts the guessed (kanji + okurigana) back to only hiragana (what I want), but then type another hiragana, and it starts to guess again... this is driving me crazy.

What language settings do I need to adjust so that I can input Japanese as I always have?

3

That is indeed a new feature for El Capitan:

Mac becomes even more fluent.

Japanese

Live conversion for keyboard input.

OS X El Capitan dramatically improves the ease and speed of entering Japanese text. With an enhanced vocabulary and improved language engine, it automatically transforms Hiragana into written Japanese as you type — eliminating the need to press the space bar for individual word conversions.

You can disable Live Conversion under System Preferences > Keyboard > Input Sources > Japanese, or the shortcut in the Input Menu Item by clicking Open Japanese Preferences:

enter image description here

  • this does not help me, if I type in hiragana for ogenki it changes it to kanji if i hit escape it goes back but if I try to put a space it makes it kanji again. This is very annoying for learning since I don't know kanji. – PixMach Apr 10 '18 at 18:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .