3

Spelling autocorrect and checking seem to have changed in Big Sur.

I have disabled Edit > Spelling and Grammar > Check spelling while typing, I unchecked System Preferences > Keyboard > Text > Correct spelling automatically, and yet I still get text underlined, for example, in Messages:

enter image description here

Am I missing another setting somewhere or is this a bug? In previous versions I could disable this easily.

Background: I use multiple languages and although in theory macOS can tell the difference, spell-check/autocorrect is not working too well with weird languages like Hungarian.

2
  • 2
    It looks like you're using Messages in your screenshot. I see the same behavior in Messages, but it works fine in TextEdit. Bug in Messages? – negacao Nov 29 '20 at 15:38
  • Yes you are right, I now tried a different app and it worked as expected. Seems it is specific to Messages. – Aron Nov 29 '20 at 15:38
3

It seems to be limited to the Messages app (so likely a bug) and after a few times of quitting and restarting (interestingly one restart was not enough) it too seems to finally have learned the lesson.

So my recommendation to others with similar issue:

  • Set the settings as you prefer
  • Don't forget about System Prefs / Keyboard / Text / Correct spelling automatically - this is either new in Big Sur (not sure) or it was toggled on again after update
  • Patiently restart your apps a few times (or perhaps a full system restart) and this should resolve the issue
1
  • The system prefs thing worked for me. Autocorrect on your phone is annoying enough but on a Mac, with a keyboard, where you type much more accurately, is infinitely annoying. I couldn't type "Gronk"!!! – l008com Feb 7 at 12:53
0

If you want to globally turn it off, please check my answer to this same question, on this already older/existent topic:

https://apple.stackexchange.com/a/411622/341083

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .