0

In macOS there appear words that are underlined in red if the spelling is wrong. However, I started to learn French and only found that French words that are spelled correctly have he red underlines because there are no such words in English.

Is it possible not to apply the spelling check on French words? I added French on the Language and Region setting on System Preferences but still have the underlines...


UPDATE

Here is the result of adding Français to the list.

enter image description here

But the preferences on text at keyboard looks like the following:

enter image description here

The relevant item is in the middle and it reads as Based on languages spell automatically.

And French words still have the underlines.

enter image description here

This is on Note.app and on macOS 10.14.3.

1

Language and Region doesn't really have anything to do with spelling in MacOS. Instead go to System Preferences/Keyboard/Text/Spelling and set the language there, plus maybe in Edit > Spelling and Grammar > Show Spelling and Grammar if necessary.

Some non-Apple apps like Word have their own independent spelling settings.

If you need to do both languages at once, you can try the Automatic setting in Spelling, after going to the Setup item and checking the boxes for just those two languages. How well this works in practice you will have to determine by testing with your particular text.

A better solution would be to use a more advanced app like Pages or Word, where you should be able to set the language of individual text runs so that the right spell check is used for each.

I think it may work better in iOS. If you have such a device, activate the French and English keyboards and dictionaries. My initial test indicates it handles a text like yours correctly.

  • Thanks but seems that this doesn't work at all. Some French words have the underlines, and now some English words also have them because there are no such words in French... – Blaszard Jan 25 at 17:49
  • I updated it with pics. Sorry for the Chinese language setting. If it is unclear let me know. – Blaszard Jan 26 at 8:37
  • @Blaszard You are right, it does not work with 2 languages in one line. How about different lines for each language? I think many users find Apple's "automatic" not that helpful for their particular needs. – Tom Gewecke Jan 26 at 14:40
0

In this case, the built-in spell checker is failing and not much can be done.

I found an application called Spelling Corrector 7.1 by Alpha Omega Software which does offer this.

I am not affiliated with this software.

It offers instant spell checking in multiple languages including French:

You need a spelling corrector to check the spelling of the words you use in your documents? You want to perform instantaneous spelling checking in Danish, Dutch, English, French, German, Italian, Japanese, Norwegian, Portuguese, Spanish, Swedish and many other languages? Then Spelling Corrector is what you need!

Note if you install it:

Under Mac OS 10.13 High Sierra, if you're launching the Application for the first time, Mac OS' GateKeeper (which you can configure in the "System Preferences") will refuse to launch it because you've not downloaded it from the Mac App Store (but from our website). In this case, instead of double-clicking on it, all you have to do is to right-click on the Application's icon, and then select the "Open" menu. A message will appear in which you'll be able to confirm that you want to launch the Application (even if it was not downloaded from the Mac App Store from an Identified Developper).

You can download the .dmg file here and the .zip file here.

  • @TomGewecke edited post – user310476 Jan 26 at 16:22
  • This app requires you to manually enter individual words in a floating box to check their spelling. So it won't flag or check the spelling as you type text into a document. – Tom Gewecke Jan 26 at 18:28
  • @TomGewecke it’s a solution while I look for something else – user310476 Jan 26 at 18:59
  • It's not a solution for getting rid of red lines under words in multilingual text as requested by Blazard. – Tom Gewecke Jan 26 at 19:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .