10

I've just done a clean install of Yosemite, and in practically all of my apps I'm noticing those red underlines whenever I've "misspelled" something (or, more accurately, used an unrecognized name, technical term, piece of code, etc.). I have been disabling it app by app, although even then it doesn't always work - for example, when doing Google searches in Chrome it still shows up, even though I've disabled "check spelling while typing."

I've also gone to System Preferences/Keyboard/Text and unchecked "Correct spelling automatically," but this still doesn't seem to do anything.

Has something gone wrong on my system? And is there any more reliable way to completely disable this unwanted "feature?"

4

Renaming '/System/Library/Services/AppleSpell.service/Contents/Resources' did not work for me since that file doesn't seem to exist on this install (10.11). What did work was disabling it for the languages I usually write in, under System Preferences->Keyboard->Text->Spelling select menu. It's set to 'Automatic by Language' by default, choose 'Set up…' at the bottom and deselect your languages. Restart the applications that use the Spelling service.

3

Rename the contents of the AppleSpell service to append .disabled, then kill AppleSpell.

sudo mv /System/Library/Services/AppleSpell.service/Contents/Resources \
        /System/Library/Services/AppleSpell.service/Contents/Resources.disabled
killall AppleSpell
  • Thanks! How do I kill AppleSpell? – Adam Oct 19 '14 at 16:18
  • @Adam killall AppleSpell, edited answer – grg Oct 19 '14 at 16:19
  • 1
    Warning: If you are using filevault, following this steps could lead to a frozen grey screen, when trying to shutdown. (At least for me) – WhatIsName Oct 27 '14 at 21:27
  • This procedure doesn't work anymore as the Resources file does not exist anymore in System/Library/Services/AppleSpell.service/Contents in macOS Sierra – Sayan Nov 29 '17 at 2:19
-1

Under System Preferences > Keyboard > Text there is a checkbox in the top right called "Correct spelling automatically". Turn that off to disable AppleSpell.

  • 1
    The OP said they had already tried this method. – Tetsujin Apr 18 '16 at 8:53
-2

This work for me on El Capitan: https://www.osx.news/mac/turn-off-autocorrect-on-mac/

Edit: This is not a solution to the question asked. Auto-correction is not spell checking.

  • 1
    Welcome to Ask Different! While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. It was also stated by the OP that this had been tried. – Tetsujin Apr 18 '16 at 8:52
  • This link is dead. – jtheletter Aug 9 '18 at 5:26

You must log in to answer this question.

protected by Tetsujin Apr 18 '16 at 8:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .