1

I have disabled spell checker in System Preferences > Keyboard > Text.
Also, in TextEdit, under Edit > Grammar > Check spelling automatically.

Opening a document in TextEdit keeps re-enabling the app-level spell checker itself, again and again.

I am not using macOS in English. Running macOS Mojave 10.14.3

How can I get rid of this? I remember this was a bug in some previous Mac OS X version. It has been fixed back in the day.

  • 1
    It seems to set it per document, which is a bit irritating - I worked out a script to toggle it a while ago - not tested it since - apple.stackexchange.com/a/209219/85275 – Tetsujin Feb 9 at 8:36
  • 1
    Did you also disable in TextEdit > Preferences? – Tom Gewecke Feb 23 at 21:48
  • What language are you using macOS in then? – Tom Gewecke Feb 23 at 21:48
  • @TomGewecke oh my. I didn't know that can be also found in app settings. I never opened them tbh. Thanks, solved. – Tomáš Pánik Feb 23 at 21:54
1

TextEdit has yet a 3rd place where you might need to turn this off, TextEdit > Preferences > New Document > Options

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .