1

Spellcheck has stopped working in all my apps since upgrading to 12.1 and/or installing Grammarly.

Misspelled words are NOT underlined in red.

-I uninstalled Grammerly -I checked to make sure Preferences>Keyboard>Text>Correct Spelling Automatically is checked. -And checked to make sure that Edit>Spelling&Grammar>Check Spelling While Typing is checked within each app. -I ran Cocktail for macOS, cleared caches, restarted, etc.

Oddly, for some reason, some apps are not showing the checkmark to the right of "Check Spelling While Typing, but others do. In both cases, the command does not work.

I AM able to use "Show Spelling & Grammer", and "Check Document Now" in all apps.

Grateful for any suggestions.

1
  • Did you get anywhere? I have the same issue. You haven’t installed Grammarly by any chance? I thought it might be that uninstalling didn’t do anything
    – AndrewC
    Commented Mar 1, 2022 at 23:50

1 Answer 1

2

I believe the issue is Grammarly.

It turns it off so it doesn’t clash with the systems spellcheck, however, doesn’t seem to reverse the change upon quitting, disabling or uninstalling

Open Terminal and copy and paste the following:

defaults write -g NSAllowContinuousSpellChecking -bool true

You might need to reboot and check settings after.

It worked for me and I didn’t have to reboot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .