6

So this has been driving me crazy - it feels like I have a grammar troll living in my computer. MacOS's spell checker keeps flagging words as misspelled that aren't. I notice it mostly in Mail, because that's what I use most. However it's also happened in Messages and other Apple apps. It does not happen in MS Word. Usually it's trying to get me to use another similar word that is grammatically incorrect. I've attached some screenshots as well.

Hardware is a 2017 iMac 5K running 10.14.1 (non-beta), and I don't remember seeing this before Mojave. I don't have any other languages installed other than U.S. English, am located in the U.S., and don't have any settings that are anything other than what a regular, American English speaking person would have. I also don't have any other spell-check programs installed that I know of. This is only a work computer with the basics installed. Has anyone else come across this, or have any idea what it could be?

For example, the following sentences have popped up as issues (quotes are added by me here, they were not in the original text):

"The second claim is what's left, and is what you should respond to here." It flags "here" and tries to change it to "hear".

"We should go somewhere in town that's closer to downtown". It flags "to" and tries to change it to "too".

"I just contacted your office." It flags "your" and tries to change it to "you're".

"You had the proper address and were going to bring it to her." It flags "were" and tries to change it to "we're".

Does anyone have an idea of what this could be? I would suspect some rogue app doing this, but I am careful with what I install, and only have trusted apps on the machine.

enter image description here enter image description here enter image description here enter image description here

  • Any odds you found a solution that doesn't involve installing Grammarly or turning off spellchecking? – Denis de Bernardy Apr 5 at 7:09
2

According to this apple support discussion many are experiencing the same issue.

One way to get rid of is to install Grammarly for Mac and turn off apple spell check.

0

Lets first check your personal Spelling Dictionary for words you put in.

In Finder use Go-To

Go to ~/Library/Spelling/LocalDictionary

Open it to see your words and remove incorrect ones (if any).

Spell check Flags

, if it Flags a word and you know it is correct just add your correct word to your Spell check "Add to Dictionary" and ti will leave you alone on that.

Automatic Spell correction.

On High Sierra go to System Preferences > Keyboard > Text and uncheck Correct Spelling Automatically. Sorry i do not know where that is on Mojave, but probably the same.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .