0

For no apparent reason, one of the keys on my Macbook Air keyboard (the "l" key) shows the character accent pop-up menu. This happens when I tap the key normally, not when holding down the key. Could this be some odd setting that got changed? Or is it likely a hardware problem?

  • is that the capital I (India) – Ruskes Jun 13 '14 at 21:14
  • what keyboard set up do you have (English, German, ect..) 2- is there a keyboard short cut you have that would do that. – Ruskes Jun 13 '14 at 21:16
1

I would try to reset the long key press, by turning it off and turning it on in Terminal.

Write the following in Terminal:

defaults write -g ApplePressAndHoldEnabled -bool false [for Lion/Mountain Lion]
defaults write -g ApplePressAndHoldEnabled -bool NO    [for Mavericks]

and then

defaults write -g ApplePressAndHoldEnabled -bool true  [for Lion/Mountain Lion]
defaults write -g ApplePressAndHoldEnabled -bool YES   [for Mavericks]

You need to log out and in for the changes to take effect. I don't know if you have to turn it off, log out/in, turn it on, log out/in for the system to feel the change.

If it does not solve the problem, there might be some other settings involved.

Also, if and only if you are not using the long key press ability, a quick fix would be to turn it off permanently to prevent the "I" key from popping up the character accent menu.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .