23

Before upgrading to macOS Sierra, I really liked the Character Accent Menu by doing a long press on a key (for example, the character e) and being able to add an accent on it.

However, this functionality seems to not work anymore, and so far, I can't find out why?

Also, before, doing a long press on the delete button, would repeatly delete characters. Now, it is doing only one character deletion disregarding how long I'm pressing the key. So if I want to erase 10 characters, I need to press the delete button 10 times...

Also, I am not able to log off or shut down. When doing it, all applications are closed, status bar disappears but nothing happens. The dock remains here. I have no way to shut down or log out without doing a long press on the power button.

Is someone facing the same issue?

EDIT : Logging with a new user account or guest account fix all the problems. But I still would like to know what, in my user account, became corrupted during the upgrade.

5
  • I'm not have those issues, however I did a clean install not an upgrade. Sep 23 '16 at 4:19
  • I had the same problem but it disappeared after rebooting so: have you tried turning it off and on again?
    – user202713
    Sep 23 '16 at 7:12
  • Go to your Keyboard Preferences -> Keyboard. What's your key repeat?
    – Edric
    Sep 23 '16 at 7:38
  • Preferences are good. I rebooted the computer many times, problem is remaining. I also clear all the machine and user preferences related to the system and keyboard, ... Play with the different values for this command: defaults write -g ApplePressAndHoldEnabled -bool false No changes.
    – ZouBi
    Sep 23 '16 at 8:53
  • 1
    I have the same problem as the original question, and none of these suggestions worked for me. Did anyone come up with something that worked for ZouBi? Sep 25 '19 at 7:56

12 Answers 12

15

I got the same issue after a recent update now, found the answer here and it worked for me. In Terminal type

defaults write -g ApplePressAndHoldEnabled -bool true

and then log out and log in again, this should fix the issue.

3
  • 2
    This did it for me on Catalina
    – eebbesen
    Jan 13 at 18:47
  • Worked for me !
    – dgmz
    Jan 26 at 14:24
  • 1
    Great! Worked for me on Catalina just now <3 I am not sure why they disappeared?! Mar 25 at 15:10
8

Found the solution. Go to System Preferences > Keyboard > Keyboard tab > Modifier Keys(bottom right corner). Now press restore defaults and see if that works.

2

Try adding a French or Spanish input source to your list in system prefs/keyboard/input sources and restart.

6
  • French was always in my input source as it is my native language. I removed and added it, reboot. Nothing change. I can use the French input source but I would like to avoid switching between, and remember also the keys. Also, this key repeaters is bothering me. Not working at all.
    – ZouBi
    Sep 24 '16 at 8:35
  • 1
    Have you installed any antivirus stuff like webroot? This can cause such problems. Sep 24 '16 at 12:59
  • Not at all. As I mentionned, this issue appeared right after upgrading to MacOS Sierra.
    – ZouBi
    Sep 25 '16 at 4:28
  • 1
    Try setting up a new account and see if it has same problem. Sep 25 '16 at 4:35
  • Using a guest user make all the problems disappear indeed. It might be the fastest solution but my curiosity makes me wanna know what's the real problem behind my user account.
    – ZouBi
    Sep 26 '16 at 1:11
1

enter image description here

As @kees said, just try to reboot.

On mine, no problem with this tool.

7
  • Preferences are good. I rebooted the computer many times, problem is remaining. I also clear all the machine and user preferences related to the system and keyboard, ... Play with the different values for this command: defaults write -g ApplePressAndHoldEnabled -bool false No changes.
    – ZouBi
    Sep 23 '16 at 8:53
  • Is the Char View working well without the holding? Control-Command-Space to open it
    – Zooly
    Sep 23 '16 at 9:34
  • Char View is good.
    – ZouBi
    Sep 23 '16 at 9:35
  • After the command line, did you reboot ?
    – Zooly
    Sep 23 '16 at 9:40
  • Yes of course. But I found this another bug. When I try to shutdown/reboot/log out, all the applications are being closed, the dock too. But then only my wallpaper remains and my mouse. I can't do anything else except hard reboot by long pressing the power button... My system might be corrupted somewhere.
    – ZouBi
    Sep 23 '16 at 10:21
1

Just rebooting the computer fixed it for me.

0

I've just got the answer to this from Apple. Go into Settings, Keyboard and make sure the Key Repeat slider is set to Slow and the Delay Until Repeat slider is set to Short. That fixes it. If the keyboard is working too fast, the menu won't appear.

1
  • Welcome to Ask Different! I don't see how this answer relates to the OP's question.
    – Allan
    Jan 11 '17 at 16:20
0

Go to system preferences, then keyboard then go to where it says "Delay Until Repeat" drag it to "long". that will get your accents back to keeping the key depressed like for "día"...you have to keep it pressed

0

Open up the terminal and type in:

defaults write NSGlobalDomain ApplePressAndHoldEnabled -bool true

This will toggle the Character accent menu.

Restart the mac after doing this and it should work.

0
-1

I could fix the issue by following the steps here: https://www.cnet.com/news/fix-keyboard-input-not-behaving-properly-in-os-x/

Quite simple. Sorry for the troubles.

1
  • 7
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes.
    – grg
    Oct 2 '17 at 9:36
-1

A solution that works perfectly for me is to use this command:

defaults write -g ApplePressAndHoldEnabled -bool true

If you don't want to type this command again and again, you can add it in your .bashrc or .zshrc

So the accent menu will work all the time :)

New contributor
petchav is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • Same answer as provided by Jalovisko 18 months ago, which is at the top of the answers list. 7 hours ago
-2

defaults delete -g did the trick for me, you lose your default settings but hey...

-3

You just have to hold: option + e than press your letter to put the accent.

1
  • Suggest you delete this as it makes it look like you did not read or understand the question Oct 26 '17 at 2:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .