0

I've got my new MacBook Air m1 very recently. I changed default behaviour of F-keys to normal F1, F2, etc. So in order to activate 'media' keys like volume up/down I need to press Fn+F-key. Now, what I've realised is that pressing Fn with F1, F2, etc sometimes (50/50 chance) changes the keyboard layout as well! God, it is so annoying. It shouldn't be so 100%. I think that's just a bug. So, how can I disable Fn for changing my keyboard layout?

2
  • 1
    There is a box for making Fn/Globe change keyboards in system preferences > keyboard which you should uncheck. Have you done that? – Tom Gewecke Mar 20 at 12:42
  • God! I missed it at the very surface of the section! Just put your comment as solution :))) Thank you a lot! – Timur Fayzrakhmanov Mar 20 at 13:08
1

This new feature of MacOS Big Sur can be turned off by unchecking a box in System Preferences > Keyboard.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .