Firstly, this is for High Sierra

I've already tried this step:

Character Accent Menu doesn't appear anymore in macOS Sierra

  • Add a second language like French in Settings -> Keyboard -> Input Source

  • When I type defaults read -g ApplePressAndHoldEnabled in a Terminal I got a 1

  • Go into Settings, Keyboard and make sure the Key Repeat slider is set to Slow and the Delay Until Repeat slider is set to Short.

Even if I restart the Accent Menu doesn't appear.

And this is my Mac:

macOS High Sierra | version 10.13, MacBook Pro (Retina, 15-inch, Mid 2015)

  • 1
    Do you have any antivirus stuff installed, or 3rd party apps that are aimed at text handling? Try setting up a new user account and see if you still have the problem when logged into that. Oct 3, 2017 at 0:36
  • @TomGewecke oh your right, when i create a new account i got the accent menu, and after delete apps after apps i discover that was Filezilla... but it's only work in Notes actually
    – florian-do
    Oct 3, 2017 at 8:31
  • 1
    Hey I followed your steps and then restarted my computer. Everything worked perfectly afterwards
    – John
    Oct 3, 2017 at 8:41
  • @florian-do If your issue was related to Filezilla and has been solved, please detail what you did to fix it in an answer below to help future people who may have this problem.
    – Tuesday
    Oct 3, 2017 at 17:58
  • @timothymh hello, as i said in my previous comment, the accent menu is only showing on the 'notes' app and finaly it's not related to Filezilla
    – florian-do
    Oct 4, 2017 at 8:12

2 Answers 2


Like @TomGewecke said the only way I found to solve this bug was to create another user or to reinstall Mac OS High Sierra


MacPilot has a setting that allows you to enable the accent menu in:

Apps > System > Interface > Pressing and holding keys shows accent menu

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .