0

Recently, I upgrade to macOS Big Sur (11.0 Beta (20A4300b)). After upgrade, my tp-link usb wifi adapter(Archer T2U Plus model) no longer works.

I had tried to reinstall the driver, and even other driver from gitHub.

I also tried doing smc reset, nvram reset. Nevertheless, after restarting, my extended wifi adapter still can't work.

There is no issue regarding the wifi adapter itself. I am able to successfully connect adapter with my other laptop. Either type-c port directly or with a usb to type-c converter inbetween, both ports can recognize the adapter correctly. The adapter would start to blink after plug-in in 2 seconds, yet the adapter won't be able to blink at all for the Big Sur.

What can I do to make Big Sur work with this wifi adapter?

P.S. This is my working laptop, I had to bought this adapter after work from home period since its internal wifi is terrible. Even after the upgrade, the interal wifi still suffer network inconsistent issue heavly. Therefore I had to rely on the external wifi adapter to get decent network. While I upgraded the system, I didn't backup the system, so I can't time machine it back. And also wipe out the system would not be a good approach for me, especially still in lock down period.

4
  • 1
    It's usually not a good idea to install beta software on your main computer. – nohillside Jul 13 '20 at 6:12
  • 4
    Not having a backup is foolish. Not having a backup and upgrading to early beta OS is very foolish. – benwiggy Jul 13 '20 at 7:28
  • 1
    Please read this answer regarding what a developer beta is – Allan Jul 13 '20 at 12:32
  • You could reinstall the latest macOS version compatible with your Mac using macOS Recovery. The installer should replace the OS without deleting your data. Press Option-Command-R and see support.apple.com/HT204904 for further details. Before doing so, back up your Mac (see support.apple.com/HT201250). – jaume Sep 18 '20 at 13:04
3

Some types of kernel extensions – including USB Networking – are deprecated in macOS 11.

These kernel extensions have to be rewritten by the vendor using DriverKit to be compatible with Big Sur. See https://developer.apple.com/support/kernel-extensions (USB networking).

While macOS 11 is in development, you can enable the loading of deprecated KEXTs by disabling SIP. See https://developer.apple.com/documentation/macos-release-notes/macos-big-sur-11-beta-release-notes (Deprecations).

1

Contact the vendor to get a driver which is compatible with Big Sur. It may take a while for the vendor to do so though (Big Sur is still in Beta after all), or never happen if they rather focus on selling you new stuff.

Alternatively you may try https://github.com/chris1111/Wireless-USB-Big-Sur-Adapter (which is linked from the Github page in your post) or ask the author to include support for your model.

1

I face the same issue, I just plugged my Android phone with a USB cable and I enabled USB tethering on the phone and macOS Big Sur recognised it perfectly.

Then I downloaded Mojave, made a USB pen drive for it and was able to go back to my old operating system.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .