0

I had a sweet setup for using uBar for favourites and the MacOS Dock for seeing open applications before I upgraded to Big Sur.

I had used commands from this Ask Different question: Is there a way to completely disable Dock?

Even after I upgraded to Big Sur, everything for working fine perfectly. I toggled some Dock settings in System Preferences and now I'm unable to get the auto-hide working. It is inconsistent now. It doesn't always auto-hide and gets in the way of other windows by covering them.

  1. I only want to access the Dock using Cmd+Opt+D
  2. I know the Dock will show up in the Launchpad and ^+Up and that is fine.

How do I fix this? I tried commands from the same question for restoring dock as well, and restarted the MacBook Air multiple times.

Please help.

0

I executed commands from this HowToGeek article to reset the Dock and restarted the Mac; which didn't help (yet). I had used both the commands - "The Simple Fix" killall Dock and "The Slightly Less Simple Fix" defaults delete com.apple.dock; killall Dock.

Then I relaunched the Finder as recommended in the same article and now I'm back to my fantasy setup.

Sorry for the bother, I hope this helps others as well. I had to set preferences for dock again. On Big Sur we no longer need to follow the Terminal commands from the Ask Different question mentioned above.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .