I'm trying to install Big Sur on a USB so that I can boot from the separate installation on the usb. Note, I'm not trying to create an installation USB. I followed the directions here and everything worked, except after installation, at the final stage of the boot it just hangs.

I've tried this on a few different macs, and they all hang at the same step. Booting up in verbose mode gives the following final output before hanging (this may be a little off because I used OCR, but I tried to correct what seemed relevant, note in this log it was attached to a thunderbolt port):

<date> locathost com.apple.xpc.launchd[1] <Notice>: Early boot complete. Continuing system boot.
ALF, old data swfs pid_entry <ptr>, updaterules_msg <ptr>, updaterules_state <ptr>ALF, old data sufs pid_entry ptr> updaterules_msg <ptr>, updaterules_state
<date> localhost con.apple.xpc.Launchd[1] (com.apple.iomfb_fdr_loader.31) <Error>: Missing executable detected. Job: `com.apple.iomfb_fdr_loader`
Waiting for DSMOS...
dev_init:297: diskl devi accelerated crypto: (compiled @ Jan 24 2021 20:57:23) dev init:300: diskl device_handle block size 4096 block count 122061321 features 16 internal solidstate
nx kernel mount :1134: diski initializing cache w/hash_size 8192 and cache size 32768 nx_kervel_momt:1482: diskl checkpoint search; Largest xid 8330371, best xid 6330371 @ 20
container unload:1497: vnode_close() invoked in the container unload path ALF, old data swfs pid_entry <ptr>, updaterules_nsg <ptr>, updaterules state <ptr>8810018268us
AppleThunderboltGenericHAL::earlyWake - complete - took 8 milliseconds
AppleThunderboltGenericHAL::earlyWake - complete - took 0 milliseconds
IOThunderboltSwitch(100)::listenerCallback - Thunderbolt HPD packet for rid = 1 route = 0x0 port = 9 plug = 1
IOThunderboltSwitch(100)::listenerCallback - Thunderbolt HPD packet for rid = 1 route = 0x0 port = 9 plug = 1
IOThunderboltSwitch(100)::listenerCallback - Thunderbolt HPD packet for rid = 1 route = 0x0 port = 10 plug = 1
IOThunderboltSwitch(100)::listenerCallback - Thunderbolt HPD packet for rid = 1 route = 0x0 port = 10 plug = 1

It seems like maybe the problem is with com.apple.iomfb_fdr_loader but I'm having trouble finding anything related to this erring.

Some things I've tried:

  • I've tried booting on several different macs (all running Big Sur) and this happens on all of them. So it probably has something to do with the usb or installation.
  • I've tried reinstalling mac os on the drive several times, and none of them booted so it wasn't a fluke with writing.
  • I was able to turn this same usb drive into a mac installer drive, and that booted up fine, so it seems likely there's some nuanced flag I forgot to set on the usb.
  • I tried resetting the parameter ram, but that didn't help.
  • I tried installing Catalina instead, but all I could find was the dmg for Catalina, and didn't want to go through the process of first writing that somewhere then trying to install it, but that may be my next step if a separate drive doesn't work (see below).

The one thing I haven't tried is seeing if I follow the same process for a different usb drive if I encounter the same issue. That should at least narrow it down to the process of installing or the image itself.


Using a different device with the same image did work, so it seems like this is a hardware problem with the usb device. However, I've been unable to get this to work with multiple different usb-c devices.

Catalina also worked, so this seems to be something funny with Big Sur.

I've also be unable to upgrade from Catalina to Big Sur once the installation is working.

2 Answers 2


Get a new drive. That process is quite a bit longer than you might think you need, but it’s the safest and most direct correct solution. If you have errors with the install it’s likely these are the causes in order:

  1. Bad USB storage
  2. Bad download of the installer (very unlikely, but it happens)
  3. Not following the guide
  4. Failure of the Mac (more likely USB port or cable or hub)

Catalina and Bog Sur are well vetted now. When you asked this, Big Sur is still getting some edge cases patched up, but either should work well now for anyone facing this situation.


I actually tried this myself yesterday and it works to perform the install but the same as the original post happens to me as well (Big Sur only). Brand new Sandisk Pro SSD USB drive - 128GB. Not sure if it's something with Sandisk? What USB stick did you end up using? And did you ever get this working with Big Sur?

Side note: Catalina works just fine. Using it now on the same stick.

  • Please provide additional details in your answer. As it's currently written, it's hard to understand your solution.
    – Community Bot
    Aug 28, 2021 at 21:35
  • I spent a long time with apple support, they said they escalated, but I never heard back. At some point I remember reading about the way boot is set up from bigsur onward that prevents running it from an external drive. I wish I remember the source, but I think you're stuck at using catalina.
    – Erik
    Aug 30, 2021 at 1:34
  • @Erik Any luck with recent Catalina updates? I ran the latest and got the same result as I do with Big Sur during the next boot. Had to do a recovery install to get back up and running. Hesitant to do it again to see if in-fact it was the Catalina update or maybe the Big Sur update trying to take it's place.
    – metalcated
    Sep 12, 2021 at 14:53
  • @metalcated unfortunately no :'( I don't think it's possible
    – Erik
    Sep 14, 2021 at 1:30
  • Man that sucks. Time to wipe the drive on my MacBook then and scrap the USB stick install. Can't not have security updates etc. being installed and running the OS while out and about. Dang you Apple! :P
    – metalcated
    Sep 15, 2021 at 2:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .