3

Upgraded to Big Sur on a mid-2015 MacBook Pro. The upgrade appears to complete successfully, but at the login screen, when I click an account and enter the password, I briefly see a beach ball, then an interminably spinning "wheel" below the account name/pic like this.

macOS spinner

I have tried various workarounds to no avail, including:

  • Force shutdown and boot again
  • Safe boot
  • Boot to recovery mode, run Disk Utility and run First Aid on the internal disk and Macintosh HD and Macintosh HD - Data partitions. Confirmed permissions on user directories /Volumes/Macintosh HD/Users/*username* appeared correct.
  • Enter password, then hold Option key while clicking login button (instead of pressing Enter key); tried in both normal and safe boot modes.
  • Boot to recovery mode, delete /Volumes/Macintosh HD/var/db/.AppleSetupDone and reboot. At the language selection screen, when I click the button to proceed, it is stuck with the spinning wheel.
  • Boot to recovery mode, touch /Volumes/Macintosh HD/var/db/.AppleSetupDone, touch /Volumes/Macintosh HD/var/db/.RunLanguageChooserToo and reboot. No Language selection screen appears during boot. Instead, I see account names/images to click and sign on.
  • Boot to recovery mode and disable System Integrity Protection and retry many/most previous workaround efforts.
  • Boot to recovery mode and find /Volumes/Macintosh HD/Library/ | grep com.apple.LaunchServices | grep csstore; deleted csstore files found. Did the same for /Volumes/Macintosh HD/private/var/folders and rebooted.
  • Boot to recovery mode and renamed/moved user's Preferences directory: /Volumes/Macintosh HD/Users/*username*/Library/Preferences to Preferences-old. Rebooted.
  • Boot to recovery mode and run resetpassword. Reset password for user and rebooted.
  • Booted to single user mode ( command -S during boot), planning to try a troubleshooting step or 2. The environment loaded was restricted (no root-level access). /usr/sbin/mount -uw / failed, apparently due to permissions/restrictions.
  • Boot to recovery mode and reinstall Big Sur.

Full disclosure, NoMAD and NoMAD Login were installed/configured on this MacBook before starting the Big Sur upgrade. We've been using NoMAD and NoMAD Login at least as far back as High Sierra, so I don't think that's the trouble... Also, apparently NoMAD Login isn't loading. At the login screen, I see the Big Sur login screen, not the NoMAD Login screen. I would appreciate any tips/suggestions for other possible steps. I'd rather not wipe/format and clean install Big Sur if I can avoid that.

I managed to gain ssh access to the normally-booted system. I have an Apple Thunderbolt Ethernet adapter connected to the MacBook. The system wasn't connecting to the network (no associated DHCP lease) when booting normally, but it was connected when in recovery mode. I found if I boot the system normally, enter my password, press/hold Option and click the button to login (not sure if this is necessary), the wired network comes up and I can ssh to the machine using an administrator account. I was hoping to add another (admin) account this way, but if I try sudo [some command], the session hangs and doesn't prompt me for a password. I was able to use this method of access to reset the administrator's password, but this made no difference. Without a functioning sudo, I don't think there's a way to create a new administrator account...

After backing up critical data, I abandoned efforts to resolve the post-upgrade trouble, booted to recovery mode, used Disk Utility to delete the volume set and the Reinstall macOS Big Sur option to do a clean install. Installation went smoothly and the MacBook works normally. While reinstalling applications, I was planning to install the Spiceworks Collection Agent and encountered this nugget: Cloud Inventory Agent Install on Big Sur Crashes Finder. nmarsh2, a commenter on that post, writes, "Just wanted to chime in that upgrading a system to Big Sur where the agent is already installed causes the system to hang at login and the only solution I found was to wipe the HD and do a clean install." Moral of the story: keep a good, current Time Machine backup, at minimum.

5
  • From recovery mode, I also moved /Volumes/Machintosh HD/var/db/auth.db aside (renamed) and rebooted, which should reset authentication / remove/disable any active NoMAD Login leftovers.
    – monyker
    Mar 19, 2021 at 16:19
  • More info on NoMAD (or at least a link) might help readers (like me) who never heard of it.
    – WGroleau
    Mar 19, 2021 at 17:11
  • 1
    @WGroleau sure, sorry about that. See the updated post for links. NoMAD (No More Active Directory) is third-party software for authenticating to Windows Active Directory (comparable to Open Directory in macOS Server). NoMAD Login (aka NoLoAD) works alongside NoMAD and replaces the stock macOS login screen, allowing one to authenticate to Windows Active Directory at login.
    – monyker
    Mar 19, 2021 at 19:00
  • Can you restore from backup, uninstall NoMAD, upgrade to Big Sur and then reinstall NoMAD?
    – WGroleau
    Mar 19, 2021 at 19:54
  • @WGroleau no I mistakenly neglected to capture a current backup before upgrading. 😳
    – monyker
    Mar 19, 2021 at 21:35

1 Answer 1

0

I've seen problems with authentication after Big Sur upgrades on multiple Macs. Performing a system management controller (SMC) reset has always fixed it.

Apple has a support page with instructions for various Mac hardware here: How to reset the SMC of your Mac

1
  • I neglected to include it in the list of attempted troubleshooting steps, but resetting SMC and NVRAM were done early on. As noted in the final paragraph, a clean install of Big Sur was required to restore the MacBook to a functional machine. The source of the problem was the Spiceworks cloud/inventory agent. This is a known (now to me, also :)) problem with no known solution besides clean macOS install.
    – monyker
    Mar 23, 2021 at 12:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .