I usually change my MAC Address frequently and it worked perfectly on Catalina, however when I transitioned to Big Sur it didn't seem to work correctly, at least for Beta 4. I would run the command

sudo ifconfig en0 ether yourspoofedmacaddress

where I confirmed that en0 is my wireless device. I would expect that after running ifconfig the en0 interface ether would display the spoofed mac address, and it does, but as soon as it connects to any wifi connection, the en0 interface reverts right back to the original MAC address.

This also happens after I try to spoof any interface MAC address including en1, en2, and en3. These interfaces aren't used at all, but once en0 receives any type of network connection, all of the spoofing reverts.

Any ideas as to why it might not work anymore in Big Sur or any workarounds for that matter?

  • 1
    Just out of curiosity why do you do this?
    – Natsfan
    Aug 8, 2020 at 2:26
  • 1
    This is something you need to use the feedback tool supplied with the beta OS. It could very well be a bug and bringing it to Apple's attention is part of what you signed up for when downloading and installing beta software. Aug 8, 2020 at 17:37

2 Answers 2


I had same issue, your solution actually works

sudo ifconfig en0 ether yourspoofedmacaddress

What you have to do is hit up arrow in terminal and keep reentering it rapidly about 3 times and then it changes. I needed to do this to Login to a captive wifi and my IOT devices can't do that so have to spoof from my Mac.


I'm using an M1 MacBook Pro/Big Sur 11.2.3 I've been using the following command to generate MAC addresses:

openssl rand -hex 6 | sed 's/\(..\)/\1:/g; s/.$//'

(Also, I'd like to mention that you MUST be disconnected from any AP before attempting to change your MAC otherwise it will be refused.)

I've had no success with the previously stated claim that reentering the command multiple times somehow results in the MAC being accepted, however, I have noticed that there appears to be a pattern as to which MAC addresses are accepted and which aren't.

This is the command to change your MAC address:

sudo ifconfig en0 ether -ADDRESS-

You can easily test if It's worked or not with:


(then checking the 'ether -ADDRESS-' under en0)

Below are some of the addresses I've tested, both working and non-working:



I'd appreciate it if some of you would try these and report back as to whether they follow the same pattern for you as well. If you could also mention what hardware you are using/what version of Big Sur you have that would help.

I'll continue trying to figure out why only certain MAC addresses are accepted and report back any discoveries.

Finally, if anyone has any alternate syntax for generating MAC addresses using OpenSSL I've found quite a few online and I suspect it could be an issue with the instructions I'm giving OpenSSL in the first place.

  • I tried the first four, on a Macbook Air M1, with 11.3, and the MAC address didn't change.
    – inspirednz
    May 6, 2021 at 22:28
  • First four of the ones listed as "working?" Or the ones listed as "non-working?"
    – dry.yellow
    May 15, 2021 at 1:29
  • Those listed as working.
    – inspirednz
    May 20, 2021 at 21:33
  • This answer helped me. I simply copied the original mac address and changed the last digit and then it worked. I didn't try coming up with any pattern though. Aug 8, 2021 at 23:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .