1

I am having very strange issues with my MacBooks Airport functionality. Sometimes I cannot get any networks to show up at all. I tried a restart but even after that the issues persists.

I already purged the usual files also mentioned here

Since I even booted the computer from a MacOS 10.14 Boot device with the Wi-Fi still not seeing networks, I am suspecting a sort of hardware issue. However. Booting into Diagnostic Mode and running the tests does not show any issues.

Only booting the Mac in Safe Mode once and then booting back into normal mode solves the issue for some time.

What does Safe boot do with the Airport hardware or any other software to make it work again?

3
  • 3
    Duplicate? apple.stackexchange.com/questions/269904/… Make sure you don't have a static IP on your MacBook that interferes with another device. – slightly_toasted Nov 5 '19 at 16:26
  • thanks for the comment. Its not a duplicate, since I am experiencing a very different issue which is the opposite from the symptoms in the post you were mentioning. Also if the problem would be related to a simple solution like a static IP I would not have to post here ;) – zantafio Nov 6 '19 at 10:52
  • 1
    Well I asked the question: "Is there anything Safe-Boot does to the regular installation ( deletion of temp files, etc. ) that would explain this behaviour? " Which I was hoping to get an answer for. I edited my post acordig to your demands. – zantafio Nov 7 '19 at 11:04
1

I had the exact same problem. Are you by any chance running BBEdit? I found that the preference files were being stored as BBEdit text files rather than as ‘property list’. Trashed BBEdit and restarted... WiFi is now working

4
  • Trashing BBEdit doedsn't fix format errors in files, what did you do to solve the actual problem? – nohillside Jun 9 '20 at 8:37
  • Errr.. it worked for me. Why did BBE edit appear as the Kind in the system configuration? I have no idea. Don’t ask me to explain it. But I can tell you that when I trashed it, rebooted, the lists are all now Kind ‘property list’ and the WiFi is working. – Niall Macaulay Jun 9 '20 at 18:32
  • Well, most likely the reboot alone solved the problem for you then. The „Kind“ information just shows the default editor for editing a specific file type, it doesn‘t impact the files as such – nohillside Jun 9 '20 at 18:47
  • Interesting. But the thing is, I already spent two hours on support with Apple doing multiple reboots and safe reboots and recovery mode and reinstalled the OS ( computer only came out of the box two days ago) and yet trashing BBEdit seems to have been the one think that cured it. I’ll be sure to report back if it stays cured... – Niall Macaulay Jun 9 '20 at 23:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .