3

I’ve been trying to turn on my MacBook Pro. It goes into a black screen while it’s trying to boot ( as the progress bar reaches 50% on the Apple Logo Screen).

I am able to boot into the recovery mode and I've run the FirstAid test for my hard disk. It didn’t find any issues with the device.

Tried to login into safe mode, after the Apple logo progress screen. It goes into a spinning circle screen and it gets stuck in a loop. I waited for 15 minutes but the screen kept going blank and into spinning circle.

I have a MacBook Pro 2015 Retina running 10.14

Update - I have even tried using "Reinstall OSX" option from the recovery menu. I went through with the whole downloading and installation process. But I still end up with the same issue after booting my MacBook. I am only able to access the recovery menu.

  • Do you have auto_mount setup for your Mac? – Yudi Setiawan Apr 24 at 8:50
  • @YudiSetiawan Nope. What is it? – Jash Jacob Apr 27 at 5:04
  • Can you run diagnostics and report back if something pops up? So I take it from your update that the recovery system booted and worked just fine? This is quite odd. – n1000 May 2 at 7:10
  • Assuming you did try SMC and NVRAM reset? – n1000 May 3 at 9:50
  • @n1000 Yes. I have tried SMC and NVRAM Reset. – Jash Jacob May 3 at 10:55
2

It's possible that something in the OS got corrupted. Boot into recovery mode (hold ⌘-R on boot for those who don't know) and select the option to Reinstall OSX. It won't touch your user files or applications; it just lays down a new copy of the OS, which will likely fix your issue. You may need to explicitly connect it to your wifi/ethernet to do this. Good luck! Cheers, -j

  • Do you think I should make a backup before just in case? I'm able to user Terminal and copy data to my SD/External Hard disk. I've copied a couple of files already. I was holding off doing this "Reinstall OSX" cause I wasn't sure exactly. – Jash Jacob Apr 27 at 4:01
  • 1
    @JashJacob You should always have a backup. If you don't have one now, make one. Files with no backup are waiting to be lost. – benwiggy May 3 at 11:12
0

I would run Disk-warrior, available here, https://alsoft.com/DiskWarrior/ I'm not sure if there is a version for 10.14, their website infers there is. There is a version 10.13 and below. It isn't cheap at $120 new and $60 upgrade, but it's very, very good at unpicking a corrupted system.

If you have a clone of your OS you can load the clone download DW and run via the clone against your harddrive. They will also post you a bootable system on a USB as well (if you don't have any way of imaging the harddrive). If their bootable system doesn't work, it's a hardware fault such as RAM. Chances are DW will do the job.

I've had blank screens bootups preciously and resolved them by identifying corrupting kext files, but this sounds more serious.

0

Can you enable verbose mode, and tell us where it is getting stuck?

Boot into Single User Mode and type (exactly).
nvram boot-args="-v kext-dev-mode=1 debug=0x14e"

Then reboot.


P.S. (mods, etc.):

Technically speaking this is an answer, not a clarifying question. It will (alone) solve the issue as stated. That is, there should be no longer be a blank screen or spinning wheel of death, which is what the OP asked. ;)

However, I do intend to revise, depending on the what I hear back from @jash-jacob.

  • Although a great idea, I wonder if single user mode works as safe mode doesn't boot either. – n1000 May 7 at 11:07
  • I wouldn't expect it to - but we'd know a little more, and I thought it was funny 'cause technically, he was asking about the black screen, not the unsuccessful boot. ;) – Geoff Nixon May 7 at 13:27
  • I think I mentioned somewhere in the comment - I couldn't boot into Single User Mode. – Jash Jacob May 25 at 6:14
-2

It happened when you are updating the MacBook? If you are using non-compatible components in the mac, then maybe this will happened.

  • Based on what do you assume that the OP changed the hardware on their MBP? – nohillside Apr 24 at 11:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .