0

So the previous issue I had with my Mac Mini has morphed into a worse one and now it won't even boot normally, it just endlessly boot loops at the Apple screen. However, I have ran Apple Hardware Test twice and it comes back with "no trouble found." I'm really at my wit's end with this issue and am ready to just reinstall OS X entirely (I'm on OS X El Cap 10.11.6), but am not sure that would help...but I think it must be a software issue since I can boot to Safe Mode. Does that sound right?

So far I have tried:
- Turning the Mac Mini over and opening the bottom panel to let heat
radiate out better.
- Disconnecting everything but keyboard/mouse & monitor.
- Ran AHT several times (always just says "No trouble found."
- Booted to Apple -R to recovery: recheck disk and ran repair
permissions.
- Pulled both 8GB RAM modules (one at a time, of course) and tried booting with only one.

I'm out of ideas here. Any feedback here greatly appreciated.

EDIT: No idea how or why it's able to run in Safe Mode, but I think this must be a hardware issue because I am not able to boot to either Recovery or a Linux Mint USB. Both also cause a boot loop!

  • 1
    Boot in Verbose Mode (Cmd-V) have your camera rolling as the boot messages go by. When it crashes, you can capture any messages that get posted to the console. Also, you can attempt to search through the console log while in safe mode. Type dmesg and search to see if you see any errors. – Allan Nov 8 '16 at 0:26
  • Very helpful, thanks! In Safe Mode now, let me see here... – SamAndrew81 Nov 8 '16 at 0:51
  • I booted to verbose and the last two lines I can see in the video before the reboot happens are: bash: /ect/rc.server: No such file or directory and bash: / etc/rc.installer_cleanup: No such file or directory – SamAndrew81 Nov 8 '16 at 1:45
  • 1
    I saw a bunch of permission "denied" statements in the log. Try repairing the disk permissions. – Allan Nov 8 '16 at 3:18
1

Reinstalling from Recovery mode should work. Here is how to enter recovery mode. On a normal working computer, it usually takes a few tries to get into recovery mode as the timing is very important. Maybe try a few times to get into recovery mode. Make sure you go into the regular Recovery Mode and NOT Internet Recovery Mode.

Another thing you could try is to see if it is a hardware problem or a software problem. You could check this by creating a bootable usb drive with another OS(it doesn't really matter which OS) and attempting to boot into that OS on your Mac Mini. If booting into another OS works, you'll know it's a software problem.

If you have access to another Mac use this guide(by osxdaily) to safely install macOS onto your Mac using a bootable USB drive or use this guide(by apple).

If you need a .dmg file for macOS/OS X(to create a bootable USB on non macOS/OS X systems) try this link.

  • No dice, it's boot looping when trying to go to recovery mode now. Disk Utility says the SSD is good though... – SamAndrew81 Nov 8 '16 at 1:38
  • @SamAndrew81 on a normal working computer, it usually takes a few tries to get into recovery mode as the timing is very important. So try like 10 times or so to get into recovery mode. – abc Nov 8 '16 at 1:41
  • No, that's not the problem I'm having. I see the "world" icon and it is going into Recovery Mode...then it reboots. I'm thinking this must be a hardware issue, but everything passes in AHT. – SamAndrew81 Nov 8 '16 at 1:43
  • 1
    @SamAndrew81 I didn't mean Internet Recovery Mode, I just meant the regular Recovery Mode. – abc Nov 8 '16 at 15:31
  • 1
    @SamAndrew81 You're welcome. – abc Nov 9 '16 at 2:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .