On my Late 2016 15" MBP running 10.13.4 the Touch Bar/Touch ID are not functional, but only when I am booted in Safe Mode. The ESC key doesn't appear either (when holding the fn key) and doesn't work if I try to just imagine it's there (I tried Force Quit shortcut--cmd opt esc).

I've reinstalled the OS several times and have cleared the NVRAM but this issue has persisted and began before the release of High Sierra. From what I can gather online it seems that the Touch Bar should work when in Safe Mode since booting into Safe Mode seems to be frequently recommended when others report issues with their Touch Bar.

Does anyone have any idea what might be causing this or what files and processes might be effecting it?

  • Just to clarify: Are you saying that your Touch Bar and Touch ID do work in Safe Mode, but do not work when booted normally?
    – Monomeeth
    May 3, 2018 at 23:49
  • It sounds to me like the other way around, @Monomeeth. It sounds like the touch bar only DOESN’T work in Safe Mode.
    – NoahL
    May 4, 2018 at 12:42

2 Answers 2


Assuming I understand your problem correctly (i.e. this issue is not present during Safe Mode) then your best bet is to investigate login items, fonts, and kernel extensions.

Investigating login items, fonts, and kernel extensions

Let's start with Login Items:

  1. Startup normally
  2. Go to System Preferences > Users & Groups
  3. Select the Login Items tab
  4. Take a note of your Login Items
  5. Now remove all of them by highlighting them and clicking on the - button below
  6. Restart your computer

Now your Mac will boot up without those login items loading. Test to see if your Touch Bar and Touch ID work okay now.

  • If they work okay, you know one (or more) of the Login items were causing the problem. You can then add them back in one by one until you've identified the culprit. Problem solved.
  • If they still don't work, it's either a problem with fonts you've installed yourself or with a 3rd party kernel extension. A little more info below:

Fonts:- You can remove any of the fonts you've installed yourself to see if this makes a difference.

Kernel Extensions:- You can open Terminal (found within your Utilites folder) and enter the following command:

kextstat | grep -v com.apple

The above command will list 3rd party kernel extensions (you may need to stretch the Terminal window so it's easier to read). Look for anything you don't remember installing, or something that belongs to software you've removed, or just anything that looks out of place. Remember though, this is a list of 3rd party kernel extensions and therefore any of them could be causing the problem.

Create another user

If your Touch Bar and Touch ID still don't work after going through the above process, you could create a new user in Apple > System Preferences > Users & Groups and then log into that user to see if the problem persists. If it doesn't persist, it may be better to use that user (or create another one you're happy to use) and migrate your data across to that account.

If all else fails

If none of the above works it may be time do a totally fresh installation of macOS (your question didn't specify whether you had already tried a "fresh" installation - but if you've already tried this then it may be best to try installing an earlier version of High Sierra).

NOTE: Make sure you have a current backup if you decide to do a full fresh installation of macOS.

  • All of these things have been tried to no avail and a fresh installation has been attempted numerous times every single possible different way one can do this, including secure erasing all volumes/the entire disk on SSD. Apple has even replaced the entire laptop. Installing from Internet Recovery at various locations, Booting into Recovery in Safe Mode. Still same issue. Jun 8, 2018 at 17:13
  • What you've just described us bizarre! :( If totally fresh installations haven't worked and even having the laptop replaced didn't work, then the only thing worth trying is going back to Apple again. I assume this problem: (1) also happens before you install any 3rd party software, and (2) regardless of your location?
    – Monomeeth
    Jun 9, 2018 at 5:38
  • Yeah its quite odd. I wish there was a way to check that various files were legitimate. for ex, I've wondered if the contents of my kextexcludelist kext are correct but try asking anyone at apple that and suddenly they've never heard of a "computer" and can't help you. theres plenty of places something could hide to avoid being wiped during installation like nvram, HHD/SSD firmware, RAM, or Secure Enclave. Its interesting that the touch bar runs on its own embedded operating system, maybe there is some persistent issue with the embedded OS. Jun 11, 2018 at 4:21

I have the exact same issue. It suddenly stopped working a few days ago. I tried every possible way to revive it. At first the sudo pkill command worked but after a few sleep/ restart nothing appeared in the touchbar though blind touch seems to work but I tried switching between sierra , mojave, catilina , and could not revive the touch bar. and did factory reset and the blind touch seems to gone . Throughout all of this my Touch Id seems to work just fine and works everytime. Is there any way to determine wheather this is a hardware issue or software issue. I think I have done every possible thing that is found in the internet regarding software. I live in Bangladesh now. The laptop was bought in uk and used it there 2 years without any problem. when I brought it here in bangladesh and started using with a different account after a factory reset it worked for a few days and then boom.... any Help?

  • Welcome to Ask Different! Please refrain from adding comments in the Answer section, this is for answers to the questions. Once you have sufficient reputation you’ll be able to add comments and ask follow-up questions. To gain reputation, answer questions that are clear and concise. - From Review
    – fsb
    Oct 24, 2020 at 14:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .