6

I've been trying to solve the issue seen here:

http://www.princeton.edu/~jcjb/docs/osx_error_fix/

The recommended solution is to do a safe boot which clears various caches etc, however I'm unable to complete a safe boot. It gets stuck with the progress bar only about 5% complete; I even tried leaving the machine on overnight, about 8-9 hours.

I also tried safe booting via rEFInd which gets rid of the apple logo and lets me see what's actually happening and it's getting stuck on the 'fsck_hfs -r' step 'checking catalog file.' I ran this command manually from recovery mode on the same disk and it completed just fine in 15-20min but safe boot still gets stuck. I've also tried clearing PRAM in case that helps any.

Any other ideas for getting into safe mode? Is it possible to run the safe boot 'script' manually from recovery mode? Does such a script exist?

  • 1
    Your name is not Jim. It won’t work. Boot into single user mode and run fsck -fy. – duci9y Jan 21 '13 at 16:42
1

This appears to be covered in detail (without an answer on the Apple discussion forums (thread 1 and thread 2).

The second link in particular goes on a long way, with rumours of a workaround (though not what the workaround might be), ways to disable fsck so that it boots (though what the point of a safe boot without the fsck is I'm not sure), that it may be related to the RAM installed on the Mac, and that it may be fixed in the 10.8.3 seeds.

Good luck until it clears up.

0

I reported to Apple a number of bugs that involve safe boot. The report that's most relevant to this question was in May 2011.

For most users of Mountain Lion who were bitten by this bug, it seems that a fix was within OS X 10.8.4.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .