1

after update, on my MacBook Pro 15 inch mid 2015, from 10.14.5 to 10.14.6 my bluetooth stoped working. All of my 5 devices were listed in the System preferences -> Bluetooth, but I could only see their addresses (12 letters). There was no button to connect to any of my device.  

I tried:


  1. Removing .plist files (~/Library/Preferences/com.apple.Bluetooth.plist, ~/Library/Preferences/ByHost/ com.apple.Bluetooth.XXX.plist)
  2. Resetting SMC
  3. Resetting  bluetooth module + Removing all devices 
 But none of them helped to solve my issue. In 10.14.6 when I clicked on Remove all devices (Bluetooth Debug option) I didn’t see any device in System preferences, but when I restarted Mac I did see them (addresses).

I hoped that this bluetooth problem would resolve Catalina, but it doesn’t. Bluetooth is still not working, only change is that after I removed all devices and after restart I didn’t see devices (addresses).

In Catalina I can only see my bluetooth mouse and when I click on connect button, I can see how it is trying to connect, but not successfully (changing text from Connected to Not Connected repeatedly ... this problem I didn't have in 10.14.6). I can only see that mouse, any other devices are not shown. 

Do you have any ideas how it could be fixed? Any idea would be very appreciated.


Thank you

1

Reset PRAM/NVRAM after updating to Catalina so that any old data should be removed from the cache.

  1. Shut down your Mac.
  2. Turn it on and immediately press and hold these four keys together: Option, Command, P, and R.
  3. You can release the keys after about 20 seconds, during which your Mac might appear to restart.

It will resolved your issue. This solution worked in a couple of Macbooks of my colleagues after upgrading.

1
  • I tried it 3 times, but it doesn't help. Bluetooth doesn't find any device except mouse (still reconnecting). – ViktorR Oct 9 '19 at 16:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .