1

I have a MacBook Pro Retina (2015). After updating to OS Mojave, Bluetooth has stopped working. I get an error message that "No Bluetooth Hardware Found".

I have already tried to do the following:

  1. Go to the /Library/Preferences and delete the com.apple.Bluetooth.plist file
  2. Successfully resetting SMC. (pressing Shift+ctrl+alt + power button)
  3. Removing the Bluetooth icon from the menu bar
  4. Successfully resetting NVRAM.

None of the above solutions has worked for me.

2

It may be necessary for the Bluetooth demon to be stopped when deleting the file. Here's what worked for me (some of this may be unnecessary or redundant):

  1. Turn off bluetooth, e.g. from the toolbar icon.

  2. Run this command (you'll probably be prompted for your password):

    sudo pkill bluetoothd \
        && sudo rm /Library/Preferences/com.apple.Bluetooth.plist \
        && sudo pkill bluetoothd
    
  3. Go to the Bluetooth System Preferences pane and click the "Show bluetooth in menu bar" checkbox twice (to remove and then re-show it).

  4. In the Bluetooth System Preferences pane, delete the device you want to connect to.

  5. Turn on bluetooth.

  6. Turn that device on and in pairing mode.

  7. Pair with it.

It was not necessary for me to do anything with the SMC or NVRAM, or restart the machine.

  • You are basically deleting the com.apple.Bluetooth.plist which I already tried....didn't work :( – skm Jan 19 at 11:11
  • That and some other steps...I was not successful merely deleting it but was successful with the steps I mentioned. I can't say for sure that the extra steps were responsible for the success, but it might be worth a try for you. – Keith Bennett Jan 21 at 4:04
0

In terminal, also remove the com.apple.driver.AppleBluetoothMultitouch.trackpad.plist and com.apple.driver.AppleBluetoothMultitouch.mouse.plist files from ~/Library/Preferences.

cd ~/Library/Preferences
sudo rm com.apple.driver.AppleBluetoothMultitouch.mouse.plist
sudo rm com.apple.driver.AppleBluetoothMultitouch.trackpad.plist

Then restart. That fixed it for me.

0

A colleague of mine had accidentally removed the list of all the connected wifi networks on my system which has since resolved this issue for me!

New contributor
Rohan Vir is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • 1
    And how to do that? – skm Jun 12 at 11:30
  • @skm By going to Preferences -> Network-> Wi-Fi-> Advanced and selecting all networks and clicking - sign. BUT I think before this destructive action which also appears to be not connected to Bluetooth functionality, I suggest reboot or updates. – ankiiiiiii Jun 12 at 15:14
  • @ankiiiiiii: I already re-installed the whole OS but still did not work. I posted this question several months ago and since then I have tried several things but nothing worked. – skm Jun 13 at 6:58
  • I'm currently on 10.14.5 and had been having this issue since 10.14.2 on my MBP 2015. Bluetooth worked after a restart but then magically started showing Bluetooth not available. I know it sounds weird but as I understand, the wireless card is common for both WiFi and Bluetooth. Also, after re-installing the OS, your iCloud restores the list of connected WiFi networks so that might be a reason why it's not worked for you till now(was the case with me). Let me know if it works for you! @skm – Rohan Vir Jun 13 at 12:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .