3

macOS 10.14.6, Mail.app v. 12.4 (3445.104.11), 2015 iMac. The software is up-to-date.

I was looking for a possibly-deleted email, and searched several Time Machine backups. I found one possibility, and restored it. It turned out not to be what I sought, so I deleted it.

Now, however, I'm left with extra mailboxes in Mail.app:

enter image description here

You can see them here as "com.apple.Mail Backup" and "Recovered Messages." "Recovered messages" is empty, and I cannot delete either mailbox. Similar mailboxes in the past (when I've used TM to recover emails) were easily deleted.

I have rebuilt them both (Mail > Mailbox > Rebuild), which only makes the single I email I thought might be my target reappear in the "Recovered Messages" email folder.

I've also restarted the computer, both normally and into safe mode. These had no effect either.

I used the Mac's Finder search, and found three files named "com.apple.mail - note the difference that the word "mail" is not capitalized, as it is in these mysterious mailboxes. These files are all located on a mounted bootable backup disk which is updated nightly using ChronoSynch. The file path displayed in the Finder window says these files are located at the root level of the bootable disk in a folder named "private." Opening the bootable disk reveals no folder named "private."

I'm mystified. Can anyone explain what's going on here? How can I get rid of these folders?

EDIT: I moved the "Recovered Messages" mailbox up to the top of the mailbox list, then quit and restarted mail, selected the moved mailbox, then used the "Delete Mailbox" command at Mail > Mailbox > Delete Mailbox. The mailbox disappeared. Perhaps moving it had something to do with the success, or perhaps thinking so is a post facto fallacy. The other mailbox remains.

  • Just now tried again to delete the mailbox using Mail > Mailbox > Delete Mailbox command...and the mailbox deleted immediately. Not posted as an Answer because I have no idea why it worked today, but hadn't up to this point. – David yesterday

You must log in to answer this question.

Browse other questions tagged .