I have just set up a new mac and migrated the user accounts from the old system (Snow Leopard) to the new one (Mountain Lion) and everything went well except for some parts of the Mail setup.

In the old computer there were several mailbox (.mbox) directories on the Mac itself. These mailboxes were transferred to the new computer and it looks like they were successfully processed by the migration into a new directory structure.

However the mailboxes do not show up in the new Mail program.

(Note that the mbox's directly related to the email POP accounts did successfully transfer to the new mac)

For example, there is a mailbox called Travel and for a particular email message it is located in the old and new systems as:


And the text in 24307.emlx in the new location matches that of the old location.

So the question is how do I get these local mbox folders to appear in the Mail app? Do I have to manually configure something under the hood, or is there a user configuration somewhere that I have missed?

2 Answers 2


Have you tried doing like this?

  1. Navigate to: Macintosh HD → Users → Your User Folder → Library.

  2. Now you need to copy the Mail folder, as shown below. (Yes, the entire folder.)

  3. You should also copy the preferences file for Mail.app. Here's where you can find it: Macintosh HD → Users → Your User Folder → Library → Preferences. The name of the file is com.apple.mail.plist.

  4. Copy the Mail folder and the preferences file to the Library and Preferences folder. Make sure that the folder and file are in the correct location!

Source: http://www.macinstruct.com/node/183

  • Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone.
    – nohillside
    Commented Aug 8, 2013 at 12:00
  • 1
    Understood, I've made an edit with a summarized version of the links content Commented Aug 8, 2013 at 12:11
  • @AndreasNorman As mentioned in my question, the mail folders already have been copied to the new computer as a part of the migration. The problem is getting the mail app to recognize them.
    – Peter M
    Commented Aug 8, 2013 at 17:23
  • did you copy the com.apple.mail.plist file? or is it too late for that? Commented Aug 9, 2013 at 16:03

OK .. I solved my problem and it is a combination of face palm plus a generous serving of hating Apple.

This was what I was seeing in the Mail app after the migration, and there was nothing I could see in the preferences that would tell me how to display the files that I knew were in the correct location.

enter image description here

Then by total fluke I moused over the "On My Mac" label and saw:

enter image description here

Which revealed the hidden setting which I can't even see mentioned in the help file. When I click on Show I finally see what I have been looking for:

enter image description here

Maybe its a pebkac error for not memorising 100% of the Mail apps features, but Apple sure doesn't make it an obvious UI element or mention it anywhere I can find.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .