1

I recently had to restore my ~/Library/Mail folder from a Time Machine backup, and upon opening Mail it imported the mailboxes seemingly successfully, however my Smart Mailboxes no longer function, despite appearing to be correct.

My smart mailboxes aren't anything fancy, they basically just group similar items; for example, if accounts A and B both have an IMAP folder named "Newsletters" then the corresponding smart mailbox simply combines messages that reside in either folder; it's a simple match any rule for each mailbox.

However, even though these smart mailboxes appear to be valid (pointing to the correct mailboxes), nothing is appearing within them at all. I've already tried rebuilding every mailbox, as well as closing Mail, clearing its entry under ~/Library/Containers (to force it to rebuild its cache) and relaunching. I've also tried creating new smart mailboxes, but these don't work either, so there must be an index somewhere that's not functioning correctly, but I've already tried deleting the envelope index files under ~/Library/Mail/V2/MailData.

Is there anything else I can do to solve this problem?

  • I have had to delete and recreate them in the past – user151019 Feb 21 '15 at 13:28
  • I've tried that as well, but they don't seem to be working at all. I seem to have run out of things I can delete and recreate at this point! I've even tried recreating my Spotlight index, though I'm not sure if Mail uses this for its smart mailbox searches or not. – Haravikk Feb 21 '15 at 14:58
  • could we see a example of smart box set up you have that is not working. – Ruskes Feb 26 '15 at 19:36
1

I'm going to assume you are using Mail 8.2.

Have you checked the permissions on the SmartMailBoxesLocalProperties.plist in ~/Library/Mail/V2/MailData? For reference my plist -rw-r--r@.

When you state new smart mailboxes are working, does this mean they aren't being saved also? The fact that new mailboxes aren't working either seems to point to a permissions problem, as seen in this previous question.

  • This answer seems semi-correct; it does appear to have been a permissions issue, but not on a Mail specific file. Instead the issue appears to have been with either my user folder, or my ~/Library folder. When I restored the user account I didn't restore everything, so I re-created the user folder and library folder manually, so I could avoid restoring large files I wanted to handle later. The permissions appeared correct but there must have been something wrong. Quite why this broke Mail I can't begin to imagine though. – Haravikk Mar 3 '15 at 10:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .