I have a 1TB backup plus drive (Seagate) formatted using ExFAT, to be able to use it on Mac OS. I'm using an Early 2015 Macbook Pro Retina (13"), running OS X El Capitan 10.11.6.

From when I first started using the hard drive, it works perfectly fine once it's mounted. When it has been ejected improperly (yes, I know, I shouldn't, but it happens by accident sometimes) it will take ages (+- 20min) after plugging it in again for it to mount (show up in Finder). I tried opening Disk Utility to check if it shows up there, it never does. The delay is always there. Disk Utility just shows a spinner and doesn't even load my main HDD, unless I plug out the external HDD.

Also tried various commands in the Terminal, e.g. diskutil mountDisk disk name and diskutil mount volumeName, etc. Nothing seems to help, the delay is consistently there.

After reboot, it always shows up immediately, which tells me it's not the disk's fault.

Anyone have a solution to this? USB service restart or something like that?

  • Why ExFAT, are you sharing the drive between Linux/Windows? Does the same delay, under the same conditions, happen with external drives formatted using the OS X native HFS+ filesystem? Commented Oct 22, 2016 at 13:51
  • Indeed, I need to be able to use it on Windows occasionally, so HFS+ is not an option unless I obtain a driver (which I don't want). Commented Oct 22, 2016 at 13:55
  • What happens if you first mount it from Windows machine, check the disk using chkdsk first after being improperly ejected, does it then mount quickly on the Mac or still a delay? Also you didn't answer the second question in my first comment. Do you have another external drive formatted HFS+ that has same delay, under the same conditions? If you don't have an another external drive formatted HFS+ that's fine, just please answer the questions asked otherwise I can't troubleshoot. Commented Oct 22, 2016 at 14:04
  • I do not currently own a HFS+ formatted drive. As for the chkdsk, yes I've tried that. It does not make a difference. Commented Oct 23, 2016 at 10:25
  • I have the same problem everytime I mount my 1TB drive on my macbook running Sierra OS. It takes about 5-10 min to mount and I am unable to see drives in disk utility! Any luck?
    – Taha I.
    Commented Nov 24, 2016 at 14:37

1 Answer 1


There's probably a duplicate question here, but the system will run a filesystem check when the device attached is possibly a foreign file system or a native Mac filesystem where the journaling feature is disabled or the journal indicates possible failures of the disk allocation catalog or directory structures.

You can usually open Activity Monitor and see some activity start when you connect the drive while the OS is checking if the drive is correct before showing it in finder. Depending on size of the volume, this could take 5 to 25 minutes or more if the drive itself has hardware malfunction.

To diagnose this, you would need a tool to disable the disk arbitration framework and then time / examine the mount process for each disk that's out of the ordinary.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .