1

So I had the external 4TB Seagate Expansion Drive, and at one point I end up selecting unmount in Disk Utility when I tried running first aid.

Now I wish to mount it again, I tried pressing the mount button in Disk Utility. No response.

I tried ejecting, unmounting, and re-mounting the backup drive in Terminal through:

  1. diskutil eject /dev/disk3s2
  2. diskutil unmountDisk /dev/disk3s2
  3. diskutil mount /dev/disk3s2

The resulting response is:

  1. Volume timed out while waiting to eject
  2. Unmount of all volumes on disk3 was successful
  3. Volume on disk3s2 timed out waiting to mount

Insofar the hardware is blinking so I guess it's functional. I just like to ask if there are any solutions possible, or should I just click the mount button and wait for it, thank you.

Bonus: Here is the Disk Utility for the external drive insofar Disk Utility, showing the Seagate Expansion Drive greyed out, not mounted

  • 2
    Have you physically disconnected it, then reconnected it ie by removing and refitting the cable - works for me – Solar Mike Sep 15 at 4:36
1

There is a 3rd party app named Mountain that lets you control volumes on you mac. The app has a free trial period and costs around $6. Also available on App Store.

0

Your operations are correct, but there is likely a file system check that’s blocking the mount.

Open Activity Monitor and then show all processes - not just the ones your user runs. Then search for fsck or a process that has that embedded.

If you see that, the last check was “dirty” and the system will need to run all the checks before making the mount happen. The only side track would be to use a program like Disk Warrior that bypasses the system check and fixes things / clears the flag for that drive.

4 TB could take a day to check worst case - so set your Mac to not sleep and connect to power if it’s portable. Unless you have hard links and Time Machine backups - then the check could run into days or a week based on the count of files to check back and forth in terms of hard links.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .