0

I was backing up my Mac today (Time Machine) when I think I jostled the USB cable. The hard drive disappeared from the finder window and progress on backing up in the Time Machine window disappeared.

I've tried unplugging/replugging the HD and restarting the computer, but it doesn't show up in finder or Time Machine anymore. The light on the hard drive is blinking, indicating it thinks its being accessed, but I don't think it's actually doing anything.

The HD DOES show up in the Disk Utility Program. However if I try to repair the Time Machine partition, it says "Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files." If I attempt to erase the partition, it says "Volume Erase failed with the error: Couldn’t open disk." And if I attempt to erase the Disk (one level up from the partition in the Disk Utility), it says "Disk Erase failed with the error: Couldn’t unmount disk."

I tried force unmounting the disk using the Terminal command, but the disk doesn't actually show up in /Volumes/, so it didn't work.

Any ideas on this one? Is the disk completely totalled or is there another way to get it to reset so I can re-back things up?

  • So, I left the HD plugged into the computer for a while today and when I came back, it had fully backed up and was working normally. I have no idea why it apparently decided to appear broken, but it seems to have worked itself out. – user208301 Oct 28 '16 at 22:41
  • I have an external HDD that I thought was dead, but it returned later. Maybe there is some cache or some corrupted file associated that confuses the system. Removable devices was never fully supported by any OS in my opinion. – Gustavo Mar 1 '18 at 14:26
1

You can use the device id as well as the mount path for diskutil. Get the device id using diskutil list (disk3 in my example) and then force unmount it:

diskutil unmountDisk force disk3

And then erase the disk (HFS+ with GUID Partitioning Table):

diskutil eraseDisk HFS+ Untitled GPT disk3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .