4

I have a strange problem. Working on an OS 10.9.5 MacBook laptop.

Last night, I was exporting a 20-something GB Aperture library from my WD 2TB drive to another hard drive. I left, and when I came back the next morning, my computer warned me that I should properly eject my hard drive. I hadn't disconnected it, and my settings are set so that the computer will NEVER go to sleep or shut down when the power supply was connected (which it was). Now, my mac won't recognize the hard drive.

  • Is it dead?
  • How can I prevent this from happening again?
  • How can I recover my files if I can't see the disk???

I've tried:

  1. Powering my computer on and off
  2. Using a different USB connector
  3. Using a different power cord
  4. Plugging the external drive into another mac (did not work)
  5. Plugging the drive into a windows computer (nope)
  6. Mounting through disk utility, or using disk utility to repair/verify the disk (got this error message: Disk utility can't repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files).
  7. Suggestions on these sites: External drive does not mount after plug off without eject and Sometimes Mac doesn't recognise my external hard drive e.g., going through terminal to unmount OR eject OR view files in read only mode (all just say the volume timed out)
  8. Read suggestions on this thread about drives disconnecting on their own - wasn't sure what to do, but realized the problem might have had something to do with exporting Aperture files? https://discussions.apple.com/thread/2597920?start=120&tstart=0

This is my time machine disk, and it has some other stuff on it I need. I also don't know whether to trust my machine to plug another hard drive into it. I can't update to a newer OS just yet. I'm terrified to plug in my other hard drives because what if the same thing happens to them!? Unfortunately all my Aperture libraries are stored on external disks!

Info:

Last login: Sun Mar 26 16:39:26 on ttys000
ericaneomputer2:~ erica$ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *320.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            319.2 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *2.0 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:                  Apple_HFS NEWTON_WD               2.0 TB     disk1s2
ericaneomputer2:~ erica$ diskutil info disk1
   Device Identifier:        disk1
   Device Node:              /dev/disk1
   Part of Whole:            disk1
   Device / Media Name:      WD My Book 1140 Media

   Volume Name:              Not applicable (no file system)

   Mounted:                  Not applicable (no file system)

   File System:              None

   Content (IOContent):      GUID_partition_scheme
   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 USB
   SMART Status:             Not Supported

   Total Size:               2.0 TB (2000365289472 Bytes) (exactly 3906963456 512-Byte-Units)
   Volume Free Space:        Not applicable (no file system)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         Not applicable (no file system)
   Ejectable:                Yes

   Whole:                    Yes
   Internal:                 No
   OS 9 Drivers:             No
   Low Level Format:         Not supported
  • When you plug the drive in, can you feel/hear the drive spinning? Does it click, or speed up and then stop, then sped up, then stop again? – NoahL Mar 26 '17 at 21:35
  • Yup, it spins and the console says it's trying soooo hard to mount it. Then after a while it just gives up. – Nova Mar 27 '17 at 4:00
2

Either your WD MyBook enclosure has failed or the disk itself has failed.

I am basing this assessment on two factors:

  • Points 4 & 5 above - that plugging it into different computers didn't work. If it doesn't work on different computers you have narrowed it down the the WD unit itself. If the problem was with your Mac, it wouldn't be present on a different computer.

  • The correct response provided by diskutil for disk1. It's highly unlikely (though not impossible), that if the enclosure wasn't functioning you would at least get erroneous information back or no information at all. The WD enclosure is reporting back that there is a drive but it has no operating system. Chances are, it's the drive.

However, you can take it a step further and do some additional diagnostics. The key here is to isolate the major individual components of the WD enclosure - the logic board and the drive itself.

So, to diagnose this you will need either of the following

  • a known working hard drive
  • a 3.5" HDD to USB adapter (I recommend this option for reasons that will become clear momentarily).

You will need to disassemble the MyBook. From my research, the case appears to be held in place with "snaps" which you just pry off so it shouldn't be too difficult to get into. There's a straightforward set of instructions on Instructables.com

Depending on the option you took above - you either need to change the drive in the MyBook or plug the old drive into the USB to SATA adapter.

If one component works (i.e the drive), then you know for a fact that the other (i.e. the enclosure) has failed; or vice versa.

If it is your drive, the USB to SATA adapter will allow you to attempt to recover your files. I have personally used Disk Drill with excellent results (it's free to use the diagnostic portion and to see if you can recover data). You will be able to make an image of the drive and attempt recovery on the image lessening the chance of total failure of the drive.

If it happens to be the enclosure, the USB to SATA adapter will allow you to continue to use the disk drive while you come up with a more permanent solution (the MyBook is essentially the same thing but with a more elegant enclosure).

If you choose the "drive method" you will still be able to get the same diagnostic results, except you won't be able to transfer or rescue any data if it happens to be the MyBook enclosure that's bad.

Now, as preventing it from happening again - well, this is a spinning hard drive which means it mechanical. It's going to fail. The only thing you can do is mitigate data loss by having a backup

  • Thanks so much Allan. I am heading out for the week to do remote field work but will try what you've suggested when I'm back. Nice to have some optimistic thoughts while I am gone. Any idea what would have prompted it to unmount itself in the first place? I've just noticed similar problems with some other drives (which I've been able to fix by moving to a different power source or choosing another cable) so I'm worried my computer is doing something to them... – Nova Mar 27 '17 at 4:03
  • There's nothing that I can think of that would cause a computer (via USB) that would cause a drive to fail. I would start at the age of the drives themselves. I just recently had to toss an old USB flash drive because it failed to mount. – Allan Mar 27 '17 at 12:23
  • Just strange behaviour considering it was working fine when I started exporting the Aperture library, then just conked midway through. – Nova Mar 28 '17 at 14:40
  • It's a common perception that because something was being done, it must have caused the failure. You exporting an Aperture volume is nothing more than standard file I/O. You could have been copying files, deleting files, backing things up, whatever. It just so happened that the failure occurred at that time. It's usually one of the two extremes - cases such as yours were you assume routine use cased the failures and then the others where they actively did crazy stuff (like wash the Macbook in water) and believe that action couldn't possibly have damaged it. – Allan Mar 28 '17 at 15:27
  • Thanks, that actually does make me feel better. I should know better (being a scientist). :P I just purchased a new backup drive. Fingers crossed! – Nova Apr 2 '17 at 18:45
0

Crazy thing for me - my Macbook Pro Retina suddenly stopped recognizing all my external drives - tried all of the recommended restarts - safe mode, PRAM, SMC, checked power cord. All drives lit & spun, but not seen in system report, Finder or Disk Utility. However, iPhone in either USB port did show up. Tried one last thing - had external drive plugged in, opened Photoshop, and in preferences went to scratch disk - and voila - there it was. Ejected, then tried with next - and it then showed up. With third disk I did not open Photoshop but it mounted correctly - maybe a little time lag but it's a 4T drive, so might have needed time to mount.

So, maybe if you have a software program that needs to find the disk (not Time Machine - did not work) - you might try finding it that way. If nothing else - do a free trial of Photoshop CC (or one month for about $10) - might save some grief/money.

Whoops - just saw where drive did not work on other computers. Maybe someone looking for answers to my issue will see this (newbie contributer here)

0

You can go into Disk Utility and try to re mount the disk (but I found that it won't always work).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .