0

I can't mount an external hard drive. I have tried booting into Safe-Mode, mounting via Disk Utility and running First Aid, which won't proceed due to the following error:

diskutil eject disk1 Volume timed out while waiting to eject

I have also gone through the steps oulined here and here, as well as using Clean My Mac.

Any suggestions?

  • Firstly, welcome to Ask Different! :) I hope you come to find this site has a lot to offer! In case you haven't already, it's worth taking the time to read the tour. In the meantime, is there anything you haven't told us? It's not clear how long this has been happening, whether it coincided with something else (e.g. improper shutdown), etc. Also, have you tried connecting it to a different port or testing with another cable? – Monomeeth Sep 3 at 5:01
1

There is a 3rd party app named Mountain which I use on my mac. It puts an icon in your menu bar and when you click on it. it will show a list of Volumes and you can mount or unmount them. The app is $6 but has a free trial period so you can test it and see if it solves your problem. See image below.

enter image description here

  • Thank you. I'll give this a shot. – Zee Sep 3 at 1:32
  • Please let me know if you have any luck. – jmh Sep 3 at 1:36
  • My screen doesn't match the above. Not sure how to access the drive. But it's listed under "Unmounted Volumes". Can't click on it. – Zee Sep 3 at 2:34
  • Click on the dark icon of the right side of the list. refer to figure. – jmh Sep 3 at 2:40
  • 1
    If Disk Utility won't mount it, there is likely a problem with the drive in the category of "likely to be a hardware fault." – Steve Chambers Sep 3 at 13:01
0

I have encountered this problem but in my case, Bootcamp had created the problem. I mounted the disk in Windows (Bootcamp) and apparently, the disk did not eject properly. So when I switched to Mac OS, I found the disk unmounted but not able to eject it. In Disk Utility it appeared pale. So I did like below:

  • Step 1
sudo lsof | grep "/Volumes"

You would see the result something like this:

mds       1071     root    6r      DIR    1,2       8192     2 /Volumes/BOOTCAMP
mds       1071     root   11r      DIR    1,2       8192     2 /Volumes/BOOTCAMP
  • Step 2

The second column is the id of a process that makes the disk in use. So you should do this:

sudo kill [processId]

In my example:

sudo kill 1071

Then your disk is free to be ejected by this command:

diskutil eject [diskIdentifier]

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .