1

I have a Hitachi rpm-5400 160GB hard drive in an Orico USB 3.0 hard drive case. The hard drive is formatted as ExFAT.

Case Drive

I plugged this drive on my Mid-2012 Non-Retina MacBook Pro and it mounts fine in both OS X El Capitan 10.11.6 and Windows 10. But when I plugged into my Mid-2014 Retina MacBook Pro running El Capitan 10.11.6 it doesn't mount. Saying the disk you inserted was not recognizable by this computer. It happens on both of the USB port on the Retina MBP.

I also tried this on a Late 2013 iMac also running El Capitan 10.11.6 and nothing happens. Not even the disk unrecognizable message. I opened Disk Utility app on the iMac, it didn't even show up.

I am pretty sure this problem is not with the drive, as the 2012 MBP mounted the drive fine. Where should I go next to fix this problem? I don't want to erase the drive because it have important informations on it and it takes very long time to copy it to another drive.

Thanks

  • Have you tried restarting all of the computers, then taking out the HD from the USB enclosure, then putting it back in? – At0mic Aug 13 '16 at 13:05
  • @IronCraftMan I restarted my computer and try taking out the hard drive, no difference. – Tom Shen Aug 13 '16 at 13:07
  • on the Mac that it does work, can you go into Disk Utility and verify/repair the drive? – At0mic Aug 13 '16 at 13:15
1

My intuition would say that the drive might be drawing a little more power than the USB spec allows and one Mac can supply that power and the other cannot, but that's just speculation.

You would need to measure the voltage or try a different drive in the same enclosure with the same two Mac to start to pick apart why you get different results on two hardware setup.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .